Error_mod_not_found in legacy DTS packages

I get the following error when clicking the ellipsis to look at a specific lookup in a legacy dts package.

The specified module could not be found. (ERROR_MOD_NOT_FOUND)

Some modules the query builder depends on could not be found. The query builder designer will not be functional.

I have recently migrated from Windows XP to Win 7 , I have installed SSMS and done all the steps for backward compatibility for DTS 2000 packages which includes adding DTS 2000 components and backward compatibility for Sql Server 2005 and moving the DLLs per instructions on the MSDN website.

I was able to edit the lookups on the DTS packages on my Windows XP machine.

Any help will be much appreciated!





pcareWIAsked:
Who is Participating?
 
lcohanConnect With a Mentor Database AnalystCommented:
Unfortunately I have no other ideas and could not reporduce your issue on my win 7 ultimate.
Win 7 is way different than XP and many components(dll's for that matter) are new or updated. Obviously the old good XP could deal with that legacy package and there's something new/missing/buggy in win 7 related to old ODBC/OLEDB/MDAC or who knows what exactly other component of Windows.
0
 
lcohanDatabase AnalystCommented:
0
 
pcareWIAuthor Commented:
I did try this solution. It did not work I added sql 2K client and then added the sp4
 The only thing i did not do was the hotfix 2151 beacuse the hotfix does not pertain to the issue i am having. Would you know more about hotfix 2151 and how to apply it.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
lcohanDatabase AnalystCommented:
If you do all the steps below on the client where you get the "...error when clicking the ellipsis to look at a specific lookup in a legacy dts package" and still getting the error I would migrate old SQL 2000 DTS packages to SSIS 2005 DTSX packages one by one.


1) Install SQL 2K client
2) SQL2K sp4
3) Hotfix 2151
4) Install SQL 2K5 client
5) The SQL 2K DTS components for SQL 2K5

0
 
pcareWIAuthor Commented:
I agree that we need to migrate the packages on some point.
But these packages were working fine when i was on windows XP. We have migrated to Win 7 which has caused this issue.How does the Win 7 migration impact the legacy packages.
Also, all the above steps have been taken, but the issue persists, any other ideas?
0
 
pcareWIAuthor Commented:
Thanks for all your help.
I was wondering if there is a Win 7 setting that I could change which would take care of the problem here?

 I did use the Windows 7 troublsheeting wizard to fix my issue, but since the issue  is not listed, i am not getting a fix.
0
All Courses

From novice to tech pro — start learning today.