Solved

.txt files open with the cmd program

Posted on 2011-03-03
6
402 Views
Last Modified: 2012-05-11
Files that have the .txt file extension open with the OS program CMD when double clicking. If the .txt files are right clicked(RC) on and then Edit is selected they open in Notepad. Also when RCed and selecting Open With, another sub menu with Notepad and Wordpad and "Choose defaul program" are shown. Choosing either Notepad or Wordpad works as expected. Selecting the Choose ... option brings up the "Open with" dialog window. Recommended programs are Notepad and Wordpad. Choosing either one works as expected. The radio selection square is greyed out.
The problem is just when double clicking a .txt file, CMD starts to run
0
Comment
Question by:twallin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 4

Expert Comment

by:denissie
ID: 35031704
Twalin,

If I understood correctly, the following should solve your issue:

First right-click on a TXT file, select Open with and then select Choose Program...
 Step 1
Then, in the popup window, check the checkbox (1), select the wanted program (2) and click OK.
 Step 2
From now on, double click on TXT files should be opened by the above chozen program.

I hope it helps.
0
 

Author Comment

by:twallin
ID: 35031866
I guess I did not explain it very well. I have done as you suggested and as you've shown in the "Open With dialog the red circled and labeled no. 1 is greyed out in my Win7 dialog.
And something I forgot to put in my first submission was that if I change the file extension to .text, as opposed to .txt, the double click works.
0
 
LVL 4

Expert Comment

by:denissie
ID: 35032009
Look into the registrty key (use regedit) "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer"

In the right pane, if there's an attribute "NoFileAssociate", change his value (from 1 to 0 if I'm not mistaken).
Then, try the "Open with" check box again...
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 59

Expert Comment

by:LeeTutor
ID: 35032440
0
 
LVL 13

Accepted Solution

by:
upalakshitha earned 250 total points
ID: 35033027
0
 

Author Closing Comment

by:twallin
ID: 35037616
Thanks. This is my first problem solved.
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

OfficeMate Freezes on login or does not load after login credentials are input.
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
This Micro Tutorial well show you how to find and replace special characters in Microsoft Word. This is similar to carriage returns to convert columns of values from Microsoft Excel into comma separated lists.
In a previous video Micro Tutorial here at Experts Exchange (http://www.experts-exchange.com/videos/1358/How-to-get-a-free-trial-of-Office-365-with-the-Office-2016-desktop-applications.html), I explained how to get a free, one-month trial of Office …

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question