How to setup LDAPS on Windows 2008 R2 Server

I purchased a SAN cert from Godaddy and am not sure what to do at this point. I have seen one answer that says to retup the request.inf as follows:

Signature="$Windows NT$"

Subject="CN=DC1.YourDomain.local"  ; enter FQDN here - must be FQDN not another name
ProviderName="Microsoft RSA SChannel Cryptographic Provider"
KeyUsage = 0xF0     ; Digital Signature, Key Encipherment, Nonrepudiation, Data Encipherment ; Alternative 0xA0 for DigSig & Key Encipher only

OID= ; Server Authentication
OID= ; Client Authentication
; OID= ; Smart Card Logon - include even if you don't use SC right now ; comment out if going to a commercial CA - include if internally issued

; CertificateTemplate = WebServer ;Change to appropriate template name or OID ;Omit  line if CA is a stand-alone CA or commercial or other non-MS CA
; SAN = "dns=server1.domain.local&dns=server1&dns=ldap.domain.local&dns=server1&ipaddress=" ; do not include if submitting to commercial CA - purchase a SAN cert and fill in during the appropriate step

Not sure if I need everything or not, but I would love some input. Also, I am using the cert for SSO from an external server, so I am not sure that setting the cert up with the Subject being the local server name (Subject="CN=DC1.YourDomain.local") would work for me. I am guessing that I need to setup an external DNS entry for the LDAP server, and use the external name as my server name (Subject="". Is that correct? Also, if I have 2 LDAP servers on my network, one being the root DC and the other the backup DC, should I be setting this cert up for the backup DC? When I open up communication between the external server and my LDAP server, my firewall will be set to only allow LDAPS communication from their IP to my IP, which will hoepfully lock it down.
Who is Participating?
TasmantConnect With a Mentor Commented:
you don't have to open any LDAP/LDAPS port on your external firewall.
if you request a certificate for a web server (using Godaddy).
just insert the FQDN of your webserver (the public name) just after "".
the common name of the certificate will be ""
i think you can remove the whole [RequestAttributes] section, unless you want alternate name ot your certificate (SAN)
remove at least the CertificateTemplate line.
remove the OID for smart card logon.
save your file to request.inf
launch the command certreq -new request.inf certreq.req
then i think you can enter the content of the certreq.req file into godaddy to request your certificate.
Greg27Author Commented:
Thanks Tasmant.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.