Solved

Problem with Outlook Anywhere

Posted on 2011-03-03
12
1,836 Views
1 Endorsement
Last Modified: 2012-05-11
Hi,

I'm having a problem with Outlook Anywhere. I've reinstalled RPC over HTTP quite a few times but it didnt help.
I also installed a GoDaddy UCC Certificate but that didnt help.

When I run TestExchangeConnectivity, I get this:-
	"Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server COMPANYSERVER.company.local." 


 	The attempt to ping the endpoint failed.
 	
	Additional Details
 	An RPC error was thrown by the RPC Runtime process. Error 14 14

Open in new window


When I try to configure Outlook 2007, after I've entered the username and password, I get this box. It seems that Outlook can't find the mailbox.
 Dialog
I've installed Exchange SP3 but that didnt help.

Ive been working on this for 3 days now and really need some help.

Thanks
Dan
1
Comment
Question by:DanJourno
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 2
  • 2
12 Comments
 
LVL 2

Expert Comment

by:garrett_boarder
ID: 35031624
What version of Exchange do you have?  Is this SBS?
0
 
LVL 5

Author Comment

by:DanJourno
ID: 35031664
SBS 2008
Exchange 2007
Outlook 2007

Thanks
Dan
0
 
LVL 5

Author Comment

by:DanJourno
ID: 35031845
Sometimes I get this from the testexchangeconnectivity website:
      Attempting to ping RPC proxy mail.company.net.
       RPC Proxy can't be pinged.
       
      Additional Details
       An HTTP 500 response was returned from Unknown.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 5

Author Comment

by:DanJourno
ID: 35031919
And this is the line from ValidPorts in the registry:-

COMPANYSERVER:6001-6002;COMPANYSERVER:6004;companyserver.company.local:6001-6002;companyserver.company.local:6004
0
 
LVL 2

Expert Comment

by:MoSBS
ID: 35032021
Did you try Telnetting to the ports to test if you have a firewall problem?
0
 
LVL 2

Expert Comment

by:MoSBS
ID: 35032040
There is also this: https://www.testexchangeconnectivity.com/
So you can test your exchange connectivity.
0
 
LVL 2

Expert Comment

by:garrett_boarder
ID: 35032108
I am not sure what version of Outlook you have but you will need to define your outlook anywhere settings under a connection tab.  It should say Outlook Anywhere or Connect to Microsoft Exchange using HTTP.  This was so much easier to configure in Exchange 2003.  So I would start with the simple stuff like making sure firewall forwarding is on for 443 and 25.  Does Outlook Web Access work?  Then we can dive into some server stuff and might need Get-OutlookAnywhere -Server yourservername to get into some nitty gritty.
0
 
LVL 5

Author Comment

by:DanJourno
ID: 35032597
MoSBS: Sorry, if you take a look at my earlier post, i said that i tried that site and i got this:

	"Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server COMPANYSERVER.company.local." 

.
 	The attempt to ping the endpoint failed.
 	
	Additional Details
 	An RPC error was thrown by the RPC Runtime process. Error 14 14

Open in new window


and this:

   Attempting to ping RPC proxy mail.company.net.
       RPC Proxy can't be pinged.
       
      Additional Details
       An HTTP 500 response was returned from Unknown.

Open in new window

0
 
LVL 5

Author Comment

by:DanJourno
ID: 35032615
OWA is working fine. Theres just a problem with the RPC/HTTP.

[PS] C:\Windows\System32>Get-OutlookAnywhere -Server companyserver
ServerName                 : companyserver
SSLOffloading              : False
ExternalHostname           : mail.company.net
ClientAuthenticationMethod : Basic
IISAuthenticationMethods   : {Basic}
MetabasePath               : IIS://companyserver.[Admin Edit]/W3SVC/3/ROOT/Rpc
Path                       : C:\Windows\System32\RpcProxy
Server                     : companyserver
AdminDisplayName           :
ExchangeVersion            : 0.1 (8.0.535.0)
Name                       : Rpc (SBS Web Applications)
DistinguishedName          : CN=Rpc (SBS Web Applications),CN=HTTP,CN=Protocols
                             ,CN=companyserver,CN=Servers,CN=Exchange Administr
                             ative Group (FYDIBOHF23SPDLT),CN=Administrative Gr
                             oups,CN=First Organization,CN=Microsoft Exchange,C
                             N=Services,CN=Configuration,DC=jobwise,DC=local
Identity                   : JOBWISESERVER\Rpc (SBS Web Applications)
Guid                       : 33f0419a-a349-4434-a887-224193dae902
ObjectCategory             : company.local/Configuration/Schema/ms-Exch-Rpc-Htt
                             p-Virtual-Directory
ObjectClass                : {top, msExchVirtualDirectory, msExchRpcHttpVirtual
                             Directory}
WhenChanged                : 3/3/2011 11:35:16 PM
WhenCreated                : 3/3/2011 11:35:16 PM
OriginatingServer          : companyserver.jobwise.local
IsValid                    : True

Open in new window

0
 
LVL 5

Author Comment

by:DanJourno
ID: 35032716
Please take a look at this:-

C:\Users\adminuser>RpcPing -t ncacn_http -s companyserver -o RpcProxy=companyserver -P "user,domain.local,password" -I "user,domain.local,password" -H 1 -F 3 -a connect -u 10 -v 3 -e 6001
RPCPing v6.0. Copyright (C) Microsoft Corporation, 2002-2006
 Exception 14 (0x0000000E)
 Number of records is: 2
 ProcessID is 12188
 System Time is: 3/4/2011 0:20:15:906
 Generating component is 14
 Status is 0xE, 14
 Detection location is 1398
 Flags is 0
 NumberOfParameters is 2
 Long val: 0x4
 Long val: 0xe
 ProcessID is 12188
 System Time is: 3/4/2011 0:20:15:905
 Generating component is 13
 Status is 0xE, 14
 Detection location is 1418
 Flags is 0
 NumberOfParameters is 0
0
 
LVL 5

Accepted Solution

by:
DanJourno earned 0 total points
ID: 35035306
All sorted.

Microsoft told me to check these services were running:-

IKE and AuthIP IPsec Keying Modules

IPsec Policy Agent

Base Filtering Engine

Windows Firewall
0
 
LVL 5

Author Closing Comment

by:DanJourno
ID: 35081169
It worked.
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this step by step procedure, you will come to know the details of creating an Outlook meeting in 2007, 2010, 2013 & 2016.
Outlook for dependable use in a very small business   This article is about using the Outlook application (part of Microsoft Office) in a very small business, or for homeowners where dependability and reliability are critical requirements. This …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question