Can't telnet into Cisco switch

I have a pair of stacked 3750 Cisco switches.  I am able to log into the web interface with no problems.  I can also log into the switch through the console port with no problems.  But when I try and telnet into the switch I get "Could not open connection to the , on port 23 : connection failed".  I have checked both the web interface and through the console and telnet has been enabled with an IP address.

Thanks in advance for any help!
DallasAdminAsked:
Who is Participating?
 
SIM50Connect With a Mentor Commented:
Is there a password set for telnet connection? It will not allow you to connect until there is a password.
0
 
lloydclintonCommented:
You have to go to the vty lines and enable login and set a password..

You should use SSH though as it is more secure..
0
 
DallasAdminAuthor Commented:
I believe I did do this.  Correct me if I'm wrong, but this are the commands I entered:

config t
line vty 0 4
login
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
_valkyrie_Commented:
Make sure you have a local user account configured (i.e.

username myuseraccount privilege 15 secret 0 mypassword
line vty 0 4
 login local
 transport input telnet

Though changing transport to SSH is a better choice.
0
 
DallasAdminAuthor Commented:
I'll try it, but it seems odd I would have to set it up on this switch when I didn't do it for any of the others in our environment.
0
 
SIM50Commented:
As experts above pointed out, you have to either configure to use local user database or a password for telnet connections. It is disabled by the default until either is set for security reasons.
0
 
_valkyrie_Connect With a Mentor Commented:
If you want to go the password on the line route, you would use:

line vty 0 4
 password 0 somepassword
 login

When I tried configuring one of our access points to use telnet -without- a password, IOS told me that it would be disabled until a password was set. Once I set the password (as above), it worked. I would still recommend the local user database with SSH over the above method.
0
 
DallasAdminAuthor Commented:
Thanks guys!  It took a little fumbling around, but you nailed it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.