Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1234
  • Last Modified:

Deleting Exchange 2007 Logs

Hi,

I just realized I have only 7.5 GB left on 200 GB dedicated disk space to Exchange Database/logs

I use NTBackup but from another server (2003 Enterprise), as exchange 2007 doesn't support ntbackup. I have been backing up by selecting the location of exchange database/logs drive from the network tree using NTBACKUP thinking it would do the trick. well it didnt and I afraid im going to run into problems. I know I cant delete them by hand either....

What can I do quickly to resolve this issue??

Thanks
0
D0TCom
Asked:
D0TCom
1 Solution
 
MISOperationsCommented:
0
 
Exchange_FreakCommented:
Dismount the DB during off hours and do a copy of the db first and then delete the log files.
This would save you since you do not have a full backup incase something happens.
0
 
D0TComAuthor Commented:
This document is first for exchange 2003. And I already run full backups on my Exchange drive.

Thanks
Ahmed
0
Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

 
uescompCommented:
You can temporarilily enable circular logging.  This will clear out your Exchange logs.  You should not delete them manually as this can cause problems.  Once the logs have cleared out you can disable circular logging again.  It should only take a few minutes for the whole process to complete.

http://technet.microsoft.com/en-us/library/bb331968(EXCHG.80).aspx
0
 
D0TComAuthor Commented:
@usecomp

I followed the instructions, restarted exchange and it free space increased only by small margin.

Ihowever now im gettig this error ...

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Mailbox Database'.

Mailbox Database
Failed
Error:
Exchange is unable to mount the database that you specified. Specified database: COBRA\First Storage Group\Mailbox Database; Error code: MapiExceptionBusy: Unable to mount database. (hr=0x8004010b, ec=-2147221237)
.




--------------------------------------------------------
OK
--------------------------------------------------------
0
 
D0TComAuthor Commented:
System Attendant service wasnt started and other exchange servers werent as well .... is that because I enables the circular loggin?

I have disabled it again and I'm in the proccess of restaring exchange....this is not good.
0
 
D0TComAuthor Commented:
Ok everything is up and running again, disbaled the circular loggin and now i have an additional 50 GB total of 100 GB. however I still see logs from july 2010.

Reason why I couldnt mount, was that I was connected to exchange via RDP use vpn and exchange services were set to start by local access. I had to start all automatic services manually to mount the database.

Still need  a permenant fix for the logs...
0
 
D0TComAuthor Commented:
Temporary Fix. Thanks for the help
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now