Solved

Samba(Solaris 10)

Posted on 2011-03-03
3
651 Views
Last Modified: 2013-12-04
Solaris 10

I've samba setup for couple of users and its working fine but I need to add about 30 more users on two different subnets. Currently I added the two users pc to the host allow line and its working but I'll like to share the dir to the entire subnet and have user use samba password to gain access to the share: When I change security to "user", add the user's PC IP, and create a smbpasswd it work fine but when I change these two lines to point it to the subnet it doesn't work
1. security = user
2. hosts allow = localhost,10.145.244.0/255.255.254.0
Samba does not work with above configuration but works fine with below configuration

# Security mode. Defines in which mode Samba will operate. Possible
# values are share, user, server, domain and ads. Most people will want
# user level security. See the Samba-HOWTO-Collection for details.
   security = SHARE

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
   hosts allow = localhost,10.40.145.103,10.40.146.77,10.40.145.83

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
 How can I setup samba share for a bunch of users on two subnet to map the dir?

Any help is highly appreciated.
0
Comment
Question by:binadmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 22

Accepted Solution

by:
blu earned 500 total points
ID: 35038701
I am not sure about this, but I suspect that samba may not accept the old style subnet mask. Instead of putting "10.145.244.0/255.255.254.0",
try using "10.145.244.0/23".
0
 

Author Comment

by:binadmin
ID: 35063235
Resolved..Thanks blu..instead of 10.145.244.0/23 I used 10.145.244.0/24...I appreciate your help. Thanks again.
0
 

Author Closing Comment

by:binadmin
ID: 35063244
Resolved..Thanks blu..instead of 10.145.244.0/23 I used 10.145.244.0/24...I appreciate your help. Thanks again.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Java performance on Solaris - Managing CPUs There are various resource controls in operating system which directly/indirectly influence the performance of application. one of the most important resource controls is "CPU".   In a multithreaded…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question