Solved

Error removing Hub transport role from Exchange 2010 Server

Posted on 2011-03-03
10
892 Views
Last Modified: 2012-05-11
Hi Guys,

I want to remove one  Exchange server 2010 used as DAG with HUB and Mailbox role it is installed at child domain. I have already installed other Exchange 2010 at other child domains in the same forest without problem. I wanted to start removing firts the hub role form this server and I am receiving the next error:
Hub Transport Role Prerequisites
Failed

Error:
Setup encountered a problem while validating the state of Active Directory: Exchange organization-level objects have not been created, and setup cannot create them because the local computer is not in the same domain and site as the schema master.  Run setup with the /prepareAD parameter on a computer in the domain CGIXXAD and site CGXXAD, and wait for replication to complete.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.267.0&e=ms.exch.err.Ex28883C&l=0&cl=cp

The setp/pl, setup/ps,setup/p , setup/pd and setup/pad was run at the root where is the schema master located without issue and we have already installed  exchange 2010 with the roles at 4 child domains but now trying to remove this server is failing with that error.

Any idea why is is failing with that error? Do I need to run again Setup.com /pd at the root. Run this setup/p again is going to affect the current exchange 2010 Servers running ok at child domain sites?

Any sugestion about this issue?

Thanks so much,
Libet,

0
Comment
Question by:CGNET-TE
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
10 Comments
 
LVL 8

Accepted Solution

by:
praveenkumare_sp earned 500 total points
ID: 35032864
Just a suggestion try this

Run setup/preparealldomains at the root or go to the child domain and Run setup/prepareAD
and then try to remove
0
 

Author Comment

by:CGNET-TE
ID: 35033059
Hi

I have already run setup /PrepareDomain:FQDN Childomain for this specific Child domain where I have the issue from the root again and It run ok. The setup/pd and prepareAD only can be run from  the root no from the ChildDOmain because the schema is at the root. I did not try again setup/prepareAD from the root again. I will try it but I just wondering why we need to run it again if it was run and it is allowing install exchange at child domains.

Thk

Libet
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35033170
i unserstand ur consern as i said  it was just a suggestion as we can be double check some of the settings
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:CGNET-TE
ID: 35036423
Yes I will try running again the setup/prepareAd and see if it help .

Thanks so much!
Libe
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35318072
may i know whether the CGNET-TE was able to set up his server
0
 

Author Comment

by:CGNET-TE
ID: 35318159
Thanks praveenkumare_sp yest running the process again at the root help with the problem.

thk
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35319215
hi CGNET-TE

I think there is mistake here, i am being given credit to this answer
please do look into it
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
This video discusses moving either the default database or any database to a new volume.

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question