Solved

Error removing Hub transport role from Exchange 2010 Server

Posted on 2011-03-03
10
884 Views
Last Modified: 2012-05-11
Hi Guys,

I want to remove one  Exchange server 2010 used as DAG with HUB and Mailbox role it is installed at child domain. I have already installed other Exchange 2010 at other child domains in the same forest without problem. I wanted to start removing firts the hub role form this server and I am receiving the next error:
Hub Transport Role Prerequisites
Failed

Error:
Setup encountered a problem while validating the state of Active Directory: Exchange organization-level objects have not been created, and setup cannot create them because the local computer is not in the same domain and site as the schema master.  Run setup with the /prepareAD parameter on a computer in the domain CGIXXAD and site CGXXAD, and wait for replication to complete.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.267.0&e=ms.exch.err.Ex28883C&l=0&cl=cp

The setp/pl, setup/ps,setup/p , setup/pd and setup/pad was run at the root where is the schema master located without issue and we have already installed  exchange 2010 with the roles at 4 child domains but now trying to remove this server is failing with that error.

Any idea why is is failing with that error? Do I need to run again Setup.com /pd at the root. Run this setup/p again is going to affect the current exchange 2010 Servers running ok at child domain sites?

Any sugestion about this issue?

Thanks so much,
Libet,

0
Comment
Question by:CGNET-TE
  • 4
  • 3
10 Comments
 
LVL 8

Accepted Solution

by:
praveenkumare_sp earned 500 total points
ID: 35032864
Just a suggestion try this

Run setup/preparealldomains at the root or go to the child domain and Run setup/prepareAD
and then try to remove
0
 

Author Comment

by:CGNET-TE
ID: 35033059
Hi

I have already run setup /PrepareDomain:FQDN Childomain for this specific Child domain where I have the issue from the root again and It run ok. The setup/pd and prepareAD only can be run from  the root no from the ChildDOmain because the schema is at the root. I did not try again setup/prepareAD from the root again. I will try it but I just wondering why we need to run it again if it was run and it is allowing install exchange at child domains.

Thk

Libet
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35033170
i unserstand ur consern as i said  it was just a suggestion as we can be double check some of the settings
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 

Author Comment

by:CGNET-TE
ID: 35036423
Yes I will try running again the setup/prepareAd and see if it help .

Thanks so much!
Libe
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35318072
may i know whether the CGNET-TE was able to set up his server
0
 

Author Comment

by:CGNET-TE
ID: 35318159
Thanks praveenkumare_sp yest running the process again at the root help with the problem.

thk
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35319215
hi CGNET-TE

I think there is mistake here, i am being given credit to this answer
please do look into it
0

Featured Post

Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Utilizing an array to gracefully append to a list of EmailAddresses
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

948 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now