Solved

Home Folder redirection will not complete on W7 workstations.

Posted on 2011-03-03
5
547 Views
Last Modified: 2012-06-22
I cannot get folder redirection to work correctly on Windows 7 workstations. We have two 2008 DCs and one 2003 DC. Folder direction has been working fine until now.

As part of virtualizing our server infrastructure, we will be moving our "home folder shares" to a new datacenter 2008 server (from a physical 2003 server). I attempted to use DFS for this purpose but ran into problems due to the 2003 server and it's inability to perform DFS synchronization. As a result I deleted my first attempt to create the new shared environment. (One thing I wonder if there is a remnant of the previous share (same name) cached somewhere causing confusion when the system tries to make the new home folder).

I have since recreated it (after I believe removing all traces of the DFS share). Now, the home folder redirection is working from XP clients; the system creates the new home directory and maps the my documents to it. From W7 clients, however, folder redirection never completes. RSOP and the event viewer initially showed the expected "will be applied at next restart". Now, the logs (as above), and gpresult indicate that group policy infrastructure has been applied successfully and that in particular the "home folder redirect" policy was successful and that folder redirection specifically was successful (in it's own event log). None the less, The documents remain in the local user's profile, the folder is never created on the server and the registry had no indication of a folder redirection. While GPresult shows the prolicy as having been applied, the setting for home folder redirection continues to read N/A.

I have found a significant number of posts regarding the failure of folder redirection and windows 7. I have checked each of the suggested settings (UAC has been disabled totally, the user does have permissions to and can create a folder on the share, the users have the necessary permissions to access the gpo, policies disable logon optimization) but still no joy.While it appears some of these people have gotten it working, the actual solution (other than above) is not clear.

I have searched for solutions to this to such a degree that I feel like I have read all indexed posts on the internet. Is there anyone that can help me resolve this issue? We will be deploying more and more w7 clients and we must find an answer to this issue - manual manipulation is not acceptable.......

I will send chocolate......
0
Comment
Question by:mahcs
  • 4
5 Comments
 
LVL 1

Expert Comment

by:klittlejohn1
ID: 35033409
Did you create the policy from the 2003 DC  for the Windows 7 clients?  I ran into problems before and had to create the group policy from the 2008 DC and had success.  Maybe try creating another policy from the 2008 DC and apply it to a Win 7 system and see it that works.  
0
 

Author Comment

by:mahcs
ID: 35036119
Thank Klittlejohn1,

I created the policy using the RSAT 2008 tools. I will try recreating the policy though to see if that helps.

The perplexing thing (did I say "the", guess I meant "one of the") is that the policy did work once for me from my windows 7 machine when I was testing. The rest of my tests were for other users from xp. At the time, I did not expect W7 to be a factor so I didn't pursue further. Then, of course, I deleted the test share and cloned the original share lun so I could take ownership and ascertain which users were going to have a problem due to directory size (permissions were never correct on our previous share). When I was ready, I deleted the clone,  created a fresh lun, recreated the  new share and applied the policy to other users. Moving forward, it never worked for those connecting using windows 7.

I did notice that even though the original share had been deleted, even before I applied the new policy to myself, my W7 client seemed to be holding some form a cache for the deleted share as I could <run>  <\\server\share\my folder> and open a folder that actually no longer existed on the network. To eliminate this, I discontiued offline files, rebooted and then turned offline files back on. The workstation no longer finds the phantom folder but I am left wondering if there is not some other cache out there. That said, the other three users I have tested this with, never had a previous folder on this share and still the systems will not create the folder. The only thing I can think of here is that perhaps the "cache" exists at the AD level, which W7 is sensitive enough to see and XP is not, causing the folders to be created in some phantom space we are not seeing? Otherwise, I am at a loss to explain the log reports of the gpo being successful combined with the fact that no folder is ever created.

Thoughts anyone? I am going a bit crazy here............
0
 

Author Comment

by:mahcs
ID: 35036717
So I recreated the policy, gave it top priority (process last, enforce) and still rsop reports it is applied yet no server folder created and local documents still pointing to c:\users.......

What's that they say about the definition of insanity???????
0
 

Accepted Solution

by:
mahcs earned 0 total points
ID: 35085097
The problem seems to have been caused by gp conflict (something was overwriting the folder redirection or causing it not to be allowed to apply). Interesting that with something as plain as folder redirection, the same policies (running on a 2008 server) affect XP clients differently than W7 clients.

I applied the policy to a test OU blocking all other inheritence and then added the other policies back in until I broke it. This was not the final solution though. Once I removed that policy, I still had to move the FR policy "up" (so it ran sooner) and enforce it.

It is finally working for all clients.
0
 

Author Closing Comment

by:mahcs
ID: 35126326
solution is not an A because the specific setting in the policy that was interfering as well was not identified.
0

Join & Write a Comment

Resolve DNS query failed errors for Exchange
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now