[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1411
  • Last Modified:

Android - Exchange Activesync configuration not "pushing" email

I just switched from BB to a new AT&T Android phone (HTC Inspire) and configured an Exchange Activesync account.  Manual sync works ok but it will not "push" email even though the update schedule for "peak" and "off-peak" times is set to push.  I removed the account and created again and hard reset the phone a few times but the behavior does not change.  Also tried on wifi.  Exchange is 2007 on a 2008 Small Business Server.  Can't figure out if the probem is with the server, the phone, or the service?  Everything else seems ok like browsing and all mail, contact, and calendar features, just don't get email unless I open the mail client, click menu, then refresh.  Thanks for help troubleshooting.
0
eldtech
Asked:
eldtech
  • 5
  • 2
1 Solution
 
Alan HardistyCo-OwnerCommented:
Do you have any other phones (not BB's) on the server that are pushing mail?

If not - please visit https://testexchangeconnectivity.com - run the Exchange Activesync test (not Exchange Activesync Autodiscover test), specify manual server settings and then post the results if the test fails. Please expand the results fully and obscure your domain name / IP Address to protect your identity.
0
 
eldtechAuthor Commented:
Yes, there's an Iphone that doesn't seem to have a problem.  testexchangeconnectivity.com returns successful on all tests.
0
 
Alan HardistyCo-OwnerCommented:
Ah - then that's the curse of the Droids!

If the iPhone is working - then either the Droid isn't configured correctly - or my article might help you out!

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2861-Activesync-Working-But-Only-For-Some-Users-On-Exchange-2007-2010.html
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Alan HardistyCo-OwnerCommented:
It could be a setting on the Droid that isn't set to Push mail - only Pull mail when you ask it.

I don't have a Droid (and have no plans to ever get one) so can't guide you through what to press.  I'll see if I can dig up something that might guide you.
0
 
Alan HardistyCo-OwnerCommented:
Ooh - that was fun!

An extract from the manual on page 77:

http://member.america.htc.com/download/Web_materials/Manual/HTC_Inspire/Inspire_AT&T_WWE_UM_110218.pdf

Changing general sync settings
From the Home screen, press MENU, and then tap Settings > Accounts & sync.

Select or clear the following:
Background data If this is selected, apps can send and receive online account
information even if you are not currently using them.
Auto-sync If this is selected, apps can use the sync schedule defined in the
account settings. If this is cleared, you will need to sync accounts
manually. For instructions on doing this, see “Synchronizing an
account manually”.

Synchronizing an account manually
From the Home screen, press MENU, and then tap Settings > Accounts & sync.
Tap the account that you want to sync.
Tap Sync now.

Changing account settings
You can change settings such as the sync frequency and the types of information
synchronized, the kinds of notification you receive, and the way that account
information is displayed.

On the Accounts & sync screen, tap the account that you want to edit.
Tap the type of information you want to sync or select an item to edit its
settings.
0
 
eldtechAuthor Commented:
Talk about missing the obvious.  Thanks so much.  
Settings > Accounts & sync -> Background data was checked but Auto-sync was not.  
It was as simple as checking Auto-sync and everything is fine.  Thanks for the help..
0
 
Alan HardistyCo-OwnerCommented:
You are welcome - presumably it should be set to Auto-Sync by default - but perhaps not.

Glad I could help and thanks for the points.

Alan
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now