?
Solved

Mobile POP Exchange Accounts Unable to send outgoing emails

Posted on 2011-03-03
29
Medium Priority
?
1,312 Views
Last Modified: 2012-05-11
We are currently migrating our mail system from Exchange 2003 to Exchange 2010. Tomorrow is deployment day. Mailbox configuration and everything is fine. The only thing that is still not a 100% is POP / mobile email. We are not using SSL or any secure certificates. For test purpose, i tried configuring a test account on the new server to an iPhone and an Android device. Initially, i was unable to configure POP account on these phones. I would set the incoming mail server address (smtp.xxxx.com) and port (25) and enter the outgoing (same smtp.xxxx.com and port 110) and it would say "unable to authenticate outgoing server". But I was able to finish configuring if I chose "Outgoing does not require authentication". But then I can receive emails, but not send emails. Currently, for our accounts in Exchange 2003, I use the same settings:
Incoming server: smtp.xxxx.com, port:25, outgoing same server and port:110. and they work fine. Is there any additional thing I need to set on Exchange 2010 to be able to authenticate outgoing emails from phones? Please help as tomorrow is deployment day.
0
Comment
Question by:isaackhazi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 16
  • 9
  • 4
29 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034042
You need to authenticate to be able to send, enter the username in the format of DOMAIN\username or username@domain.com.

Specify the username and password instead of using the "use same as incoming server"

Question though?? Why aren't you using ActiveSync?
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034148
tried domain\username, username@domain.com ... and i tried specifying username and password instead of same as incoming server config....
same result... unable to authenticate...

exchange activesync can be used on all phones? even on blackberries (with no bb enterprise setup)?
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034156
also, i made a mistake in my first post... i meant, i used port 110 for incoming and 25 for outgoing, not the other way around..
0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034178
With a blackberry you would use Blackberry Internet Service.

Most phones apart from the blackberry these days have ActiveSync
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034196
mainly the problem is, most of our senior staff work in remote branches and its hard for me to reconfigure their phones. their phones are already setup to the old exchange through pop using the settings i mentioned above. I have pointed the router to direct to the new server for pop port and smtp port. i'm configuring a android phone now. after i enter the values for outgoing server details, i get this message:

"you outgoing server does not support authentication. please verify your outgoing server settings."

incoming username is just username (it connected without specifying domain\username or username@domain.com)
outgoing i tried username@domian.com, just username, domain\username... still no use.

any idea why this is happening? why exchange the accounts on exchange 2003 are able to authenticate and not for the accounts in 2010?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034220
What authentication settings to you have configured on the default receive connector in Exchange 2010?
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034228
on exchange 2010 management console > server config > client access > pop & imap:

both pop and imap authentication settings are set to: use pain text authentication (integrated windows authentication). No TLS connection required
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034255
sorry, my mistake, both pop and imap authentication settings are set to: use pain text authentication (basic authentication). No TLS connection required

incoming server config on the phones wont authenticate unless i use basic authentication.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35034256
Have a look at the authentication methods on the Client ReceiveConnector

Create a new test user and mailbox, send the mailbox a few mails, then setup outlook to access that mailbox over POP and see if can send mail, then test from an external Outlook client if you can.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034260
Yes but what about the SMTP Receive Connector will be called DEFAULT Servername
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034294
i tried settings up pop account for the same test account on my outlook here at work, while configuring, outlook tests incoming and outgoing settings, everything completed successfully. there were two or three emails in that inbox, they were downloaded into the inbox. but when i tried sending an external email to my gmail account, i received an undeliverable message saying : Server error: '550 5.7.1 Unable to relay'

as for smtp receive connector in server config and default servername, authentication settings are:

TLS : checked
Enable domain security : unchecked

basic authentication: checked
offer basic authentication only after starting TLS : checked

Exchange server authentication: checked

Integrated windows authentication: checked

external security: unchecked
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034302
connecting to the same account through OWA, i can send and receive emails successfully.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034307
OWA isn't going to help here, and as I said you really should be using ActiveSync.

on the DEFAULT servername connector what do you have listed under the network tab? Is there any restrictions?
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034318
use these ip addresses to receive email:
(all available ipv6) : port 25
(all available ipv4) : port 25

receive emails from remote servers that have IP addresses:

::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
0.0.0.0-255.255.255.255


but for blackberry phones i still need pop right?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034323
no, as I already said, for blackberry phones you can use Blackberry Internet Service from your data provider.

Oh wait, hold on you should be using the other connector on port 587, sorry, you need to setup your router/firewall to forward port 587 and use secute SMTP on the devices.  With the authentication methods I mentioned above.
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034344
i forwarded port 587 to exchange 2010 server. on the outgoing settings on the phone, i specified port 587. now i get a different error:

"cannot connect to the mail server to verify your account information. your  server is not responding."
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 400 total points
ID: 35034354
The blackberry phones can synch mail with Exchange via WebDav, which basically means they talk to the Exchange mailbox through OWA.

I'd setup ActiveSync as it is more feature rich, more secure, quicker and easier to setup on devices than POP/IMAP
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35034362
Out of interest on the outlook POP client could you send mail to internal people? Did you set it up so it authenticated with the Outgoing server?
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034379
okay. now in order to setup active sync on the phones, what do i need to do?
do they use vpn to connect? how do they find our mailserver through the internet if no vpn is used?

for example,  for pop: our web hosting company forwards smtp.xxxx.com to our router's static IP address and i've specified port 110 to and other smtp port 25 to be forwarded to our mailserver itnternal IP address.
0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 1600 total points
ID: 35034384
to setup ActiveSync you can still use the smtp.domainname.com (as long as this is in your SSL Certificate) you just need to forward port 443 from your router/firewall to your internal IP address of your Exchange server.
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034391
dear meganuke,

when i set up the test pop account from exchange 2010 server, and tried to send external outgoing email to my gmail account, i received the error:

            Server error: '550 5.7.1 Unable to relay'

but i could send internal email from the very same exchange 2010 pop account to my exchange 2003 account.
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034395
dear demazter,

we do not have ssl certificate right now. so can i use port 80 instead?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034409
You will have a self signed SSL Certificate on your Exchange Server, it's default with Exchange 2010
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034422
oh ok... got it...
i just setup my exchange 2003 account on this android phone using exchange active sync. it said it cannot trust the ssl cert, i chose continue anyway. i was able to send and receive emails.

lemme try with the echange 2010 account now... will let u know in a few minutes.
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034444
when trying to configure exchange active sync for the exchange 2010 account, it gives an error:

your microsoft exchange server account does not have permission to sync with your current settings. contact your exchange system admin"
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35034447
under the properties of the user account is ActiveSync Enabled?
Are you logged using a Domain Admin account?
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034485
sorry about that.

i had unchecked ssl. this time i selected ssl and it worked. now i can send and receive internal and external emails through active sync on the mobile phones.

thanks demazter.

now i'll test the blackberry internet service for the test account on one of the blackberry phones here and will let you know soon.

cheers
0
 
LVL 8

Author Comment

by:isaackhazi
ID: 35034774
i've tested exchange activesync on android, iphone and nokia and set up bb internet mail service. they all work!!!

thank you guyz... i've learnt a lot today!

cheers!
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35034941
No problem, glad you have seen the advantages of ActiveSync and are going to use it instead of POP.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
This article outlines some of the reasons why an email message gets flagged as spam on a recipient's end.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question