Solved

Hyper-V on a 2008R2 Std Server

Posted on 2011-03-03
7
533 Views
Last Modified: 2013-11-06
I just built a new 2008 R2 Standard server that is a DC.
When I enable the ethernet it takes over as the DHCP server. Anyways of stopping that?
I want to use Hyper-V to run my BES.

Thanks.
0
Comment
Question by:MikeWheelz
  • 3
  • 2
  • 2
7 Comments
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 35034300
I don't understand your question. From what I can tell you have a physical machine that is a DC and is running Hyper-V. You want to run BlackBerry Enterprise Server in a VM. That should all be fine. I don't understand your issue with DHCP.
0
 
LVL 5

Expert Comment

by:HornAlum
ID: 35037660
Since that server is a DC, you should be able to go into the DHCP console and un-authorize that server as a DHCP server.

You probably, do not want to have a DC on the same machine you're trying to use as a Hypervisor, but if you have another DC on a physical machine, you should be ok.
0
 

Author Comment

by:MikeWheelz
ID: 35038979
For clarification....

Kevinhsieh - Correct. My setup is one physical server running 2008 R2 Std. This server has DC, DNS, DHCP, File services, Exchange roles running. I want to run a Hyper-V VM on this physical server for BES. IP Address for Physical server is 10.0.0.11 and 10.0.0.12 for VM.Both have their own ethernet port.

Everytime I turn on the VM, my workstations show the DHCP server as 10.0.0.12. I want them to stay on 10.0.0.11.

HornAlum - I'll check to see if the VM is showing up as a DHCP Server.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 5

Expert Comment

by:HornAlum
ID: 35039004
that's strange, that your VM shows up as the DHCP server. you definitely should go in and see if DHCP is running, and un-authorize it ... or remove DHCP on the VM.

Did you build the VM from scratch?
0
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 35039408
You can't have the same IP on both the parent and the VM. That is trying to have two servers on the network with the same IP. You need to treat the VM like it's a separate physical machine. It just happens to share the same NIC and other hardware.
0
 

Accepted Solution

by:
MikeWheelz earned 0 total points
ID: 35079031
I fixed the issue.

I had to go into the Virtual Network Manager and uncheck "Allow Management Operating System to share this network adapter."

Thanks to everyone that helped
0
 

Author Closing Comment

by:MikeWheelz
ID: 35120742
Solved the issue myself.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Every once-in-a-while, when you try to add a XenServer host to the System Center Virtual Machine Manager console, it will generate a certificate error, and the XenServer host will not be added to Virtual Machine Manager: If you are experiencing t…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question