Solved

old version

Posted on 2011-03-03
6
759 Views
Last Modified: 2012-05-11
I nvs2010 I have .net 4 as default seting and on my host server I have a asp.net setting of .4 net but my page displays an error with .net version 2?

http://www.mymrt.net/sums1/sums1/intro.aspx


i add tis line in and i get another error
Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

   <compilation debug="true" strict="false" explicit="true" targetFramework="4.0" />
0
Comment
Question by:jagguy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 13

Expert Comment

by:devlab2012
ID: 35034270
remove the changes that you made in web.config

In IIS, create a new Application Pool with target framework as 4.0.
In IIS, change your web-site to "application". For this, In IIS right click your website node in IIS and select "Convert to Application". Then select the Application Pool created in above step.
0
 
LVL 8

Expert Comment

by:Anurag Agarwal
ID: 35034306
the best thisng to solve this problem is to that if now you are using vs2010 for projects which were made in framework 2.0 (using vs2008 or vs2005 ) add new web config from vs2010 and remove/exclude old webconfig. Add all connectionstring and other keys to new webconfig as in webconfig of framework 4.0 its much different from webconfig 2.0 framework.

or else you can do    <compilation debug="true" strict="false" explicit="true" targetFramework="2.0" />
0
 

Author Comment

by:jagguy
ID: 35034769
I am making vs2010 projects using framework 4 . i am using code from older vs2008 projects but the files are all created in vs2010. I want to use .net 4

in my host panel i get IIS application pool disabled?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Expert Comment

by:Anurag Agarwal
ID: 35036962
Please mention which IIS u r using IIS6 or IIS7 secondly pls paste your webconfig file here,

is your application running properly from vs2010 ??
0
 

Accepted Solution

by:
jagguy earned 0 total points
ID: 35041793
the problem was virtual directory set up seems to work now
0
 

Author Closing Comment

by:jagguy
ID: 35081175
last comment
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Just a quick little trick I learned recently.  Now that I'm using jQuery with abandon in my asp.net applications, I have grown tired of the following syntax:      (CODE) I suppose it just offends my sense of decency to put inline VBScript on a…
User art_snob (http://www.experts-exchange.com/M_6114203.html) encountered strange behavior of Android Web browser on his Mobile Web site. It took a while to find the true cause. It happens so, that the Android Web browser (at least up to OS ver. 2.…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question