Search Engine Friendly URLs problem in Joomla

Hi,

I have set up a site using Joomla and the K2 extension and I have Search Engine Friendly URLs turned ON.

All of the links from my main menu work fine but when I try and hit an actual item, I get the following error:

404 - Item not found

When I turn SEF urls OFF it works fine and loads the item. but I dont want to turn these off.

Any ideas?

Thanks in advance.



LVL 18
Eternal_StudentAsked:
Who is Participating?
 
rashgangConnect With a Mentor Commented:
Please try to put any sef component. There are many non-commercial component availables in joomla extension.

http://extensions.joomla.org/extensions/site-management/sef


Try this
http://extensions.joomla.org/extensions/site-management/sef/1063
0
 
rashgangCommented:
Please check the query string passing same for all the menus.  that name passes alias name so please check it. other wise we need to hack it in htaccess. file

0
 
Eternal_StudentAuthor Commented:
Hi Rashgang, can you explain how I check this?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
rashgangCommented:
It will search for the alias name that is given for the article or menu name

for example

domain.com/index.php/services.html
or
domain.com/services/main.html
0
 
rashgangCommented:
can you post the live url?
0
 
Eternal_StudentAuthor Commented:
try either 1 of these links:

http://tinyurl.com/4ncf63l
0
 
rashgangCommented:
can you tell me which one is causing problem
0
 
Eternal_StudentAuthor Commented:
Click either of the content links on the above link and you will get to the error page.

404 - Item not found
0
 
rashgangCommented:
please  post the links i have tested it nothing given 404 error
0
 
Eternal_StudentAuthor Commented:
If you click this link:

http://tinyurl.com/4ncf63l

Then you will see that there are 2 items under the drawing category, both of which go to a 404 page.
0
 
Eternal_StudentAuthor Commented:
I really didnt want to install an extension to fix this problem, surely it is something I can do with the settings?
0
 
Eternal_StudentAuthor Commented:
Any ideas on what I can try?
0
 
rashgangCommented:
Please put any non-commercial components artiosef component even me also having the same trouble we cant get the correct sef url using joomla default sef bcoz it has written like that.
0
 
Eternal_StudentAuthor Commented:
didn't really understand what you just said?!?
0
 
rashgangCommented:
Even me also having the same trouble when enabling default joomla sef component. You MUST PUT ANY
any non-commercial components.

This is the best non-commercial component

Artio sef component
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.