Avatar of emumaster
emumaster
 asked on

SBS 2008 HTTP 401 - Unauthorized response was received from IIS7

I just did a new install of SBS 2008 and was running the free test at:
www.testexchangeconnectivity.com and got this error:

ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting to resolve the host name remote.allanhancockagency.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 207.68.114.92
      Testing TCP port 443 on host remote.allanhancockagency.com to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The certificate passed all validation requirements.
       
      Test Steps
       
      Validating the certificate name.
       The certificate name was validated successfully.
       
      Additional Details
       Host name remote.allanhancockagency.com was found in the Certificate Subject Common name.
      Validating certificate trust for Windows Mobile devices.
       The test passed with some warnings encountered. Please expand the additional details.
       
      Additional Details
       The certificate is only trusted on Windows Mobile 6.0 and later versions. Devices running Windows Mobile 5.0 and 5.0 with the Messaging and Security Feature Pack won't be able to sync. Root = OU=Go Daddy Class 2 Certification Authority, O="The Go Daddy Group, Inc.", C=US.
      Testing the certificate date to confirm the certificate is valid.
       Date validation passed. The certificate hasn't expired.
       
      Additional Details
       The certificate is valid. NotBefore = 3/3/2011 3:44:26 PM, NotAfter = 11/23/2011 8:15:36 PM
      Checking the IIS configuration for client certificate authentication.
       Client certificate authentication wasn't detected.
       
      Additional Details
       Accept/Require Client Certificates isn't configured.
      Testing HTTP Authentication Methods for URL https://remote.allanhancockagency.com/Microsoft-Server-Activesync/.
       The HTTP authentication methods are correct.
       
      Additional Details
       ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic
      An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the Exchange ActiveSync session.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       Testing of the OPTIONS command failed. For more information, see Additional Details.
       
      Additional Details
       A Web exception occurred because an HTTP 401 - Unauthorized response was received from IIS7

I'm not sure even where to begin??
Help!!!!
SBS

Avatar of undefined
Last Comment
Shreedhar Ette

8/22/2022 - Mon
Shreedhar Ette

Download the app for windows from https://store.accessmylan.com/main/diagnostic-tools and Post back the results.
emumaster

ASKER
Here it is:
Testing 207.68.114.92 (SSL, On Internet):

Communications:
      Doing DNS lookup on 207.68.114.92 ........ OK (static-207-68-114-92.alt.east.verizon.net)
      Testing TCP to 207.68.114.92 port 443 .... OK
SSL Certificate:
      Receiving ................................ OK
      Ensuring not Self-Signed ................. OK
      Verifying certificate .................... FAIL
ActiveSync:
      Checking for application ................. OK
      Checking version ......................... FAIL

Result:
      Username or Password incorrect.

      (For more detailed diagnosis and possible solutions, see www.accessmylan.com )
Shreedhar Ette

Observed that the 207.68.114.92 not resolvng to remote.allanhancockagency.com

Also check the certificate is installed properly.

Make you are using the proper username and password.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
emumaster

ASKER
I double check user name and password and the user is there with that name and password.
I've only created the one use so far (other than the admin and the user I am using is not in the admin group)
emumaster

ASKER
new result when I leave off the domain:

Testing 207.68.114.92 (SSL, On Internet):

Communications:
      Doing DNS lookup on 207.68.114.92 ........ OK (static-207-68-114-92.alt.east.verizon.net)
      Testing TCP to 207.68.114.92 port 443 .... OK
SSL Certificate:
      Receiving ................................ OK
      Ensuring not Self-Signed ................. OK
      Verifying certificate .................... FAIL
ActiveSync:
      Checking for application ................. OK
      Checking version ......................... OK (8.1)
      Checking protocols ....................... OK (1.0,2.0,2.1,2.5,12.0,12.1)
User Permissions:
      Checking "MHemberger" .................... OK

Result:
      ActiveSync IS available but the certificate name is incorrect.

      (For secure ActiveSync without certificate hassles, see www.accessmylan.com )
Shreedhar Ette

In Name/IP use the remote.allanhancockagency.com and see.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
emumaster

ASKER
If I use a browser , I can get to remote.allanhancockagency.com.

Yet the test shows this:

Testing remote.allanhancockageny.com (SSL, On Internet):

Communications:
      Doing DNS lookup on remote.allanhancockageny.com  FAIL

Result:
      Failed to resolve the DNS name.
Shreedhar Ette

Shreedhar Ette

Fix the DNS issue. For that get in touch with the ISP.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
emumaster

ASKER
I'm in my godaddy account and looking at the domain records.
I have an A record for remote.allanhancockagency.com and its ip is 207.68.114.92

Its first A record(just A) is pointing to godaddy's parked server(we don't have a website for this name)

It also has an MX  @    remote.allanhancockagency.com

Is the problem having the first A record pointing to godaddy servers?
emumaster

ASKER
using other dns free lookups, doesn't have problems locating the remote.allanhancockagency.com
emumaster

ASKER
Solved it myself.
The main A record pointing to godaddy servers was wrong.
It should have pointed to my static ip. Same as the remote
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
ASKER CERTIFIED SOLUTION
Shreedhar Ette

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.