Solved

False no conection report in Windows 7

Posted on 2011-03-04
13
1,423 Views
Last Modified: 2012-05-11
A user's laptop connects to the Internet without a problem, but the icon in the system notification area reports no connection.  If I open the indicator, the connection to the local WiFi shows as connected, but the report at the top says not connected - connections are available.

If I go to the Network and Sharing center, there is a red X between the computer and Internet.

I have tried uninstalling and redetecting the adapter and installing a new driver downloaded from Intel.  Nothing has worked.

What do I have to do to get the correct indications?
0
Comment
Question by:rhavey
  • 7
  • 6
13 Comments
 
LVL 69

Expert Comment

by:Merete
ID: 35042051
Make the wireless default possibly.
refs to>If I go to the Network and Sharing center, there is a red X between the computer and Internet
Do you also have an ethernet cable connection
Part of a local area network?
Can you access other computer/s

0
 
LVL 69

Expert Comment

by:Merete
ID: 35042055
For your reference
Network sharing center on my windows 7 with windows xp
wired
Network-sharing-Center.jpg
0
 
LVL 1

Author Comment

by:rhavey
ID: 35044195
Thanks Merete,

It doesn't make any difference whether I am wired or wireless.  The connection works, but the OS reports that there is no connection.

On your second post, there is a red X where Network 2 appears on your diagram.

I have tried with 2 different access points of my own and an open connection that my neighbor maintains.   All 3 connections behave the same way.
0
 
LVL 69

Expert Comment

by:Merete
ID: 35045103
Hi rhavey
this holds the key>but the icon in the system notification area reports no connection.
Aside from internet connection do you have access to the public folder.

That icon reflects an ethernet connection, not the wireless connection.

The problem lies in the network
so the steps
what does the troubleshoot wizard offer
r/click that icon and troubleshoot problems..
Have you turned off the windows firewall?
Pulled the cable out and reseated it.

first check everyone is in the same workgroup
has a unique name
Rt click on Task Bar > Properties > Notification Area Tab >customise which icons and notifications appear in the notifications area>Customise> Check Network System Icon Box >
In Network sharing Center go over to the left>change advanced sharing settings>
Turn on network sharing discovery
turn on public folder
etc
Because windows 7 uses 128 bit encrytpion try changing it to enable file sharing for lower.
Allow windows to mange the homegroup connections

This troubleshooter: "Diagnose and repair Windows File and Folder Problems automatically" may automatically fix your problem.
This troubleshooter fixes many different problems.Run now
http://support.microsoft.com/kb/825826

What type of connection do have
how many computers and how do they connect?
Via router?
0
 
LVL 1

Author Comment

by:rhavey
ID: 35074913
Merete,

Thanks again for the effort, but nothing has worked.

The troubleshooting wizard does nothing,
Windows Firewall on/off has no effect.
The situation is the same with wired and wireless networks. I have used wired connections at 2 different desks and wirelesconnection to 2 access points on my network an one that a neighbor maintains as an open connection.
The other changes had no effect.
The KB article is for XP.  I am using Windows 7.  The FixIt would not run.

My network runs OK.  Actually the computer in question connects OK, but the indication in the system tray says I have no connection.

It may not be OK.  Because the network is not detected, I cannot designate the connection as "Home" or "Work".  The Network and Sharing Center tells me that I am connected to a Public network and will not let me change the designation.
0
 
LVL 69

Expert Comment

by:Merete
ID: 35078909
Hmm red X between the computer and Internet, and you say you have no problems anywhere, internet works fine and access to the shared computer works??
 must windows firewall.
What you said here I dont understand please fill in details>> I cannot designate the connection as "Home" or "Work". <<  this is automatic..
Windows decides the network by what you created, workgroup or home. It will ask you if you are ona domain etc.
R/click my computer>go toadvanced settings>computer Name
also check Remote and allow connections from computers  running  any version remote desktop

Try this one
Internet Icon is a red X in the bottom right of the screen. My internet is working.
http://au.answers.yahoo.com/question/index?qid=20100507150347AAyPfvT
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 1

Author Comment

by:rhavey
ID: 35088111
What I was trying to say is that WIndows did not give me the option of selecting Home, Work, or Public when I connected to the network.  Windows forced Public and won't let me change it.  My suspicion is that the network is somehow not being connected and is therefore only capable of Public mode.

Domain or workgroup does not matter.  My "normal" network is a domain, but I connect several computers that are not part of the domain.  Additionally, my 2nd access point does not have an associated domain, nor does my neighbor's "guest" connection.

The link you gave me did not help.  it suggested that the red X was on the wired connection which wasn't used.  Although the icons are different if I connect to a wired spot on the network or a wireless access point, the result is the same - I am connected, but the indicators says that I am not.

I keep hoping that someone can tell me the registry hack that will fix this.
0
 
LVL 69

Expert Comment

by:Merete
ID: 35090267
This may not have a regestry fix, not everything can be fixed that way.
Sounds like the network card is not installed properly or has a problem.
Yellow Exclamation mark indicates you have limited or no connectivity with your network.
Change the ipv6 to ipv4
 could be caused by viiruses as well.
How to remove Yellow Exclamation mark on Lan network icon?
http://answers.yahoo.com/question/index?qid=20070813044720AAMWRUH

R/click the network icon on the taskbar
then network sharing center>then click change adapter sttings>click on the local area connection>diagnose

go to start run type
gpedit.msc
Local Computer Policy
Administrative Templates
Network
Network Connections double click << double click
on the right
Do not show the "local access only" network icon double click
Select this to enabled.
Logoff and on


network-connection-1.jpg
network-setting-2.jpg
0
 
LVL 1

Author Comment

by:rhavey
ID: 35100405
Merete,

I appreciate the suggestions.

The link to Yaohoo answers did not help.  I have reinstalled the network card drivers with drivers from both Intel and my distributor - several times.  It is unlikely to be a network card issue because the same situation occurs with both the wired and wireless connections.

The group policy edit did not seem to do anything.

You may be onto something with the IPv6 vs IPv4 comment.  If I go to the Network and sharing Center, click Change Adapter Settings, and double click the wireless connection, I get a status dialog similar to the one in XP.  THe dialog shows the IPv4 connection as having Internet connectivity and IPv6 as having no connectivity.  This makes sense because my router does not support IPv6.  Turning IPv6 off did no good.
0
 
LVL 69

Expert Comment

by:Merete
ID: 35102099
rhavey which  ethernet cables do you use?
I'm running out of ideas, is the problem on windows 7 or xp?
Do you use a router or switch?
I have networked my windows 7 to 2 xpsp2 systems
via netcom 4 port a router and each PC is using a cat 5 ethernet cable plugged into the router.
The router has  line filter.
Workgroup on each  I found it worked better than homegroup for more than 2 computers.
ipv4 address 192.168.1.2<<  2 denotes mine the others have 3 and 4 at the end.

subnet mask 255.255.255.0
default gateway 192.168.1.1

All are set to automatically detect settings, tools internet options connections>Lan

On the windows 7 system go to start run type in cmd then type in ipconfig press enter

See if this can assist you.
'Limited' Network Connectivity
http://answers.microsoft.com/en-us/windows/forum/windows_vista-networking/limited-network-connectivity/2f35bf22-9074-4d9b-a6e9-57f6785f3b7b
0
 
LVL 1

Accepted Solution

by:
rhavey earned 0 total points
ID: 35113945
Merete,

I was also running out of ideas, so I did what Microsoft calls an "in place upgrade" - a repair installation of Vista.  It worked.

I was a llittle surprised because the System File Checker found nothing wrong and this kind of problem is usually connected to the registry, which isn't affected by this kind of repair.

Thank you for your efforts.
0
 
LVL 1

Author Closing Comment

by:rhavey
ID: 35145599
I made a guess that an old method would work.
0
 
LVL 69

Expert Comment

by:Merete
ID: 35145845
Well done rhavey
and I am happy to see you have resolved it.
All the best
Merete
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

I hope this helps those who have been battling the SanDisk / U3 problem for a while. For anyone that is running Windows 7 64bit and is receiving and searching the internet for the “Windows Error: Windows has allocated a drive letter to the U3 dri…
One of the features I've come to appreciate about Windows 7 and Windows Server 2008 R2 is the ability to pin applications to the task bar. As useful a feature as I've found this, it does have some quirks.  For example, have you ever tried pinning an…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now