• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 711
  • Last Modified:

IIS 7 and forwarding

I have IIS 7 installed with URL rewrite 2.0. How do I get the web server to proxy forward? It should be web addresses in https, https:/www.ratsoft.com/dir/url and forward them internally to our web server, when and only when the dir part is present?
1 Solution
Brad HoweDevOps ManagerCommented:

For this you will need AAR as well. You can download them separately from here....

URL Rewrite Module
x86 - http://go.microsoft.com/?linkid=9722533
x64 - http://go.microsoft.com/?linkid=9722532

Application Request Routing Module
x86 - http://iis.net/downloads/default.aspx?tabid=34&g=6&i=1709
x64 - http://iis.net/downloads/default.aspx?tabid=34&g=6&i=1712

OR through the Web Platform installer by installing Application Request Routing. It will install the dependencies for you.

Configure AAR for Reverse Proxy
1.Open IIS Manager
2.Select a server node in the tree view on the left hand side and then click on the "Application Request Routing" feature:
3.Check the "Enable Proxy" check box. Leave the default values for all the other settings on this page.

Create URL Rewrite
1.Open the web.config file for you website.
2.Under the /configuration/system.webServer, add the following section and then save the file.
        <rule name="Reverse Proxy to" stopProcessing="true">
            <match url="^dir/url/(.*)" />
            <action type="Rewrite" url="{R:1}" />

make sure you have a default document setup too.

BigRatAuthor Commented:
OK, it was the ARR module which I was missing.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now