Solved

Configure Cisco ASA 5505 Port Forwarding 3389 with ASDM

Posted on 2011-03-04
9
4,258 Views
Last Modified: 2012-06-27
I have a Cisco ASA 5505 that is the gateway for a T1 connection. I'm trying to configure port forwarding to allow port 3389 to point to 192.168.3.10 using ASDM 5.2.  

I know the terminal server is configured properly. What am I doing wrong? Thank you!

  NAT Configuration
 NAT Rule
0
Comment
Question by:itsofmi
  • 4
  • 4
9 Comments
 
LVL 6

Expert Comment

by:djcapone
ID: 35038652
I am not as familiar with the ASDM as the command line, however, your static nat configuration is definitely incorrect.

I believe you want to change the "translated" interface from inside to outside.
0
 
LVL 3

Author Comment

by:itsofmi
ID: 35038943
I changed the translated interface to outside and that did not work.

I have the command interface up but I'm not familiar with it at all. Is there anything I can pull up that would help?

Thanks!
0
 
LVL 6

Expert Comment

by:djcapone
ID: 35039006
if you posted your running configuration with the public ips and passwords removed (for security purposes) i can give you the commands to run to get your translation working.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 35039028
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 3

Author Comment

by:itsofmi
ID: 35039090
Here is my running configuration, Thank you
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password ***** encrypted
passwd ***** encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.243 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 69.128.92.211 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
object-group service RDP tcp-udp
 description Remote Desktop
 port-object eq 3389
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service RDP2 tcp
 port-object eq 3389
access-list inside_nat0_outbound extended permit ip any 192.168.80.0 255.255.255.224
access-list outside_access_in extended permit tcp any host 69.128.92.210 eq ssh
access-list outside_access_in extended permit tcp any host 192.168.3.10 object-group RDP2 inactive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPool 192.168.80.10-192.168.80.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (outside,inside) tcp 192.168.3.1 ssh 69.128.92.210 ssh netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.3.10 3389 netmask 255.255.255.255
static (inside,outside) 69.128.92.210 192.168.3.1 netmask 255.255.255.255
access-group outside_access_in in interface outside
route inside 10.1.1.0 255.255.255.0 192.168.3.1 1
route inside 10.1.10.0 255.255.255.252 192.168.3.1 1
route outside 0.0.0.0 0.0.0.0 69.128.92.209 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.3.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.3.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd dns 4.2.2.1
dhcpd auto_config outside
!
dhcpd address 192.168.3.100-192.168.3.200 inside
dhcpd enable inside
!

group-policy BosworthVPN internal
group-policy BosworthVPN attributes
 dns-server value 4.2.2.1
 vpn-tunnel-protocol IPSec
username admin password ******* encrypted privilege 15
username nuwave password ******* encrypted privilege 15
tunnel-group BosworthVPN type ipsec-ra
tunnel-group BosworthVPN general-attributes
 address-pool VPNPool
 default-group-policy BosworthVPN
tunnel-group BosworthVPN ipsec-attributes
 pre-shared-key *
tunnel-group VPN_1 type ipsec-ra
tunnel-group VPN_1 general-attributes
 address-pool VPNPool
tunnel-group VPN_1 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:c6dae8f75fd78caf49836b1bf2ed0ad4
: end

Open in new window

0
 
LVL 6

Expert Comment

by:djcapone
ID: 35039136
ok...the existing static (inside,outside) tcp interface 3389 192.168.3.10 3389 netmask 255.255.255.255
 command should be translating the IP correcting for you (basically, the change from inside to outside in ASDM worked here)

The problem seems to be in your access-list...

access-list outside_access_in extended permit tcp any host 192.168.3.10 object-group RDP2 inactive

that line seems to be set to be inactive.

at the confiugration prompt (after logging in, typing enable, entering the password, conf t, enter)

you should see something like configasa (config)#

At that prompt type:

no access-list outside_access_in extended permit tcp any host 192.168.3.10 object-group RDP2 inactive
access-list outside_access_in extended permit tcp any host 192.168.3.10 object-group RDP2
exit
copy run start
hit <enter> to confirm

then trying connecting
0
 
LVL 3

Author Comment

by:itsofmi
ID: 35039462
Ok, I ran that command and it appears to be enabled now but I still can't remote in from outside the network. I can SSH the ASA from outside.
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password ***** encrypted
passwd ***** encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.243 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 69.128.92.211 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
object-group service RDP tcp-udp
 description Remote Desktop
 port-object eq 3389
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service RDP2 tcp
 port-object eq 3389
access-list inside_nat0_outbound extended permit ip any 192.168.80.0 255.255.255.224
access-list outside_access_in extended permit tcp any host 69.128.92.210 eq ssh
access-list outside_access_in extended permit tcp any host 192.168.3.10 object-group RDP2
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPool 192.168.80.10-192.168.80.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (outside,inside) tcp 192.168.3.1 ssh 69.128.92.210 ssh netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.3.10 3389 netmask 255.255.255.255
static (inside,outside) 69.128.92.210 192.168.3.1 netmask 255.255.255.255
access-group outside_access_in in interface outside
route inside 10.1.1.0 255.255.255.0 192.168.3.1 1
route inside 10.1.10.0 255.255.255.252 192.168.3.1 1
route outside 0.0.0.0 0.0.0.0 69.128.92.209 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.3.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.3.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd dns 4.2.2.1
dhcpd auto_config outside
!
dhcpd address 192.168.3.100-192.168.3.200 inside
dhcpd enable inside
!

group-policy BosworthVPN internal
group-policy BosworthVPN attributes
 dns-server value 4.2.2.1
 vpn-tunnel-protocol IPSec
username admin password ***** encrypted privilege 15
username nuwave password ***** encrypted privilege 15
tunnel-group BosworthVPN type ipsec-ra
tunnel-group BosworthVPN general-attributes
 address-pool VPNPool
 default-group-policy BosworthVPN
tunnel-group BosworthVPN ipsec-attributes
 pre-shared-key *
tunnel-group VPN_1 type ipsec-ra
tunnel-group VPN_1 general-attributes
 address-pool VPNPool
tunnel-group VPN_1 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:e314d360b4bca59964879db609311cd0
: end

Open in new window

0
 
LVL 6

Accepted Solution

by:
djcapone earned 500 total points
ID: 35039623
oops sorry...wrong ip in the access-list should be your public IP address or the interface...

no access-list outside_access_in extended permit tcp any host 192.168.3.10 object-group RDP2
access-list outside_access_in extended permit tcp any interface outside object-group RDP2

0
 
LVL 3

Author Closing Comment

by:itsofmi
ID: 35039837
You are awesome, that worked! Thanks!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now