Link to home
Start Free TrialLog in
Avatar of miteldatanet
miteldatanetFlag for United States of America

asked on

Publishing Sharepoint Through Xenapp 4.5, javascript errors

Hello,

I am assisting a customer who is experienceing an issue publishing a Sharepoint intranet as a published app in Xenapp 4.5.

The intranet page loads fine but we keep experiencing javascript errors throughout the site. One script in particular does a client side redirect to a SQL reporting services report.

We can manually type the URL of the SQL report and it functions fine through citrix. The issue arises on the sharepoint site where the script that redirects to the SQL reporting server's url does not run.

It seems like all javascripts are not running through citirx with new users. If I log on to the Citrix Server locally as the user account everything works fine.

Now, here is the wierd part.

If I log on locally to the server with the users account and log off immediately, I can now log on to the Citrix published application and all works fine.

Now, if I delete the users roaming profile we are back to square one.

Javascript errors throughout the sharepoint site through Citrix. Until, I log on locally and log off on the server. After the log on locally, everything works fine in Citrix.

Any idea what would cause this behauvior and how can we resolve.

ASKER CERTIFIED SOLUTION
Avatar of sabby447
sabby447

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial