Avatar of miteldatanet
miteldatanet
Flag for United States of America asked on

Publishing Sharepoint Through Xenapp 4.5, javascript errors

Hello,

I am assisting a customer who is experienceing an issue publishing a Sharepoint intranet as a published app in Xenapp 4.5.

The intranet page loads fine but we keep experiencing javascript errors throughout the site. One script in particular does a client side redirect to a SQL reporting services report.

We can manually type the URL of the SQL report and it functions fine through citrix. The issue arises on the sharepoint site where the script that redirects to the SQL reporting server's url does not run.

It seems like all javascripts are not running through citirx with new users. If I log on to the Citrix Server locally as the user account everything works fine.

Now, here is the wierd part.

If I log on locally to the server with the users account and log off immediately, I can now log on to the Citrix published application and all works fine.

Now, if I delete the users roaming profile we are back to square one.

Javascript errors throughout the sharepoint site through Citrix. Until, I log on locally and log off on the server. After the log on locally, everything works fine in Citrix.

Any idea what would cause this behauvior and how can we resolve.

GroupwareCitrixMicrosoft SharePoint

Avatar of undefined
Last Comment
sabby447

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
sabby447

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23