• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 505
  • Last Modified:

Slow speed in SQL Pervasive calls on certain router conditions

I use Pervasive SQL (ODBC has Pervasive Engine loaded)
On certain locations (meaning different locations in the country,)  when connected on the router (by hub) it takes some 20 seconds before SQL  responds, if I disconnect network cable its fast!
0
BIAPRO
Asked:
BIAPRO
  • 8
  • 4
1 Solution
 
Bill BachPresidentCommented:
Can we assume that the database is on the local system, with data on the local hard disk?
Otherwise, this makes little sense, as without the NIC cable, the call will fail.

Can you set yp Wireshark and get a network trace of the calls going out over the network?  I expect that you'll see a call going out that does not get a reply -- perhaps a DNS lookup, based on the time -- and if you know what is failing, you can figure out how to fix it.
0
 
BIAPROAuthor Commented:
Yes the database is local,  as I stated when not on the network conneted ist fast, i just have to disconnect every time my internet
will download wireshark and test it
0
 
BIAPROAuthor Commented:
when connected to the net and using a test call in the odbc to the database whiresharks generated the attached log.
my ip in this log is 192.168.1.36 for this workstation
the log itself does not (with my level of knowledge)  not tell me what makes the delay on the odbc / sql call

shark1.jpg
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
BIAPROAuthor Commented:
0
 
BIAPROAuthor Commented:
0
 
Bill BachPresidentCommented:
The problem seems to be the MDNS queries, which are issued, but no reply ever comes back.  Here's a starting point:
    http://laurachappell.blogspot.com/2009/06/iphone-youre-sexy-but-you-talk-too-much.html
But you can query mDNS in your favorite web search tool for more information.

These multi-cast DNS queries are being issued when you are connected to the network, but the system is waiting for a response.  You will probably find the system runs faster after you take some steps to disable it.
0
 
BIAPROAuthor Commented:
hi Bill, it was searching and searching , I did discover 2 networkprinters wich were on usb anyway, so turned off their IP's, but more important to this problem I discovered this way that the pervasive engine was not only looking for Ms-TCP/IP mode but multi mode.
After turning all mode's off, and only left Ms-TCP/IP mode on did solve the problem
Thanks
0
 
Bill BachPresidentCommented:
Can you post the exact steps you used to disable the other modes?  That will make this article a perfect reference for someone in the future.
0
 
BIAPROAuthor Commented:
this tab in pervasive settings

modes.jpg
0
 
Bill BachPresidentCommented:
Wow!  I forgot all about those options from Pervasive.SQL 2000i!  In all of the newer engines, it is merely a checkbox for TCP.  I would guess, then, that you wouldn't have an issue with any of the newer engines.
0
 
BIAPROAuthor Commented:
I understand Bill,  but since I have a few (and coming) pervasive dos users (netware) in the process off stepping from total dos  tpo total windows (perv. v10 and up)  I must use 2000i since I was never able to get the Btrieve dos client working in Perv. v10+
and some programs are still not converted from dos to VB6 and can't miss them
0
 
BIAPROAuthor Commented:
this way I  can run on XP both VB6 and compiled dos on the same server
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 8
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now