?
Solved

IIS settings for webresume from home network windows 7

Posted on 2011-03-06
11
Medium Priority
?
320 Views
Last Modified: 2012-05-11
Hello Experts:

 I am trying to get my resume running from my home network using windows 7 & ISS 7. I need the basics (I hope). I have IIS okay when I go internally to http://localhost/. I can view what I a want internatly. I cannot get IIS to work with my top level domain or resolve towards the outside. Is from inside to the outside what IIS 7 needs to know.... (right?)

My high-level domain name is yyyXXX.com. I have it with register.com pointing to our home network address - then port forwarding to this machine. This if have to will be another troubleshooting I can do separately. It is IIS that I need to have setup correctly.

All help is welcome and appreciated.

 Thanks!
0
Comment
Question by:marceloNYC
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 6

Accepted Solution

by:
DewFreak earned 400 total points
ID: 35046419
Does it open when you access it by IP address?  If not then your forwarding in your firewall is not correct.  Also, if you do not have static IP for your home router your IP will change eventually and your DNS entry will be invalid.  You should use some type of dynamic DNS service unless you have static IP.

Also, have you opened port 80 in the Windows firewall on your Windows 7 machine?
0
 
LVL 2

Expert Comment

by:garrett_boarder
ID: 35053112
You may also want to check your binding in IIS 7.  You will want to make sure that port 80 is listening to all available IP's.  Also make sure your Win 7 PC has a static IP to make your port forwarding from your router work.
0
 
LVL 30

Assisted Solution

by:Brad Howe
Brad Howe earned 1600 total points
ID: 35056481
Hi,
Could you comment on the following?

IIS Bindings
1. Confirm your IIS Host Bindings are *,unassigned, Port 80 OR named as *,yyyXXX.com, Port 80.

DNS Setup
2. Open CMD and type nslookup yyyXXX.com. Does this yield your WAN IP or Local IP?

Port Forwarding
3. On your router, you are port forwarding or NAT'ing port 80 to your Local IP?

Test Firewall Access
4. You can telnet to your webserver on port 80 from your WAN IP.
             telnet yyyXXX.com 80  
         CTRL-X to kill it if it connects.
Disable your firewall if it doesn't connect.

Cheers,
Hades666
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 

Author Comment

by:marceloNYC
ID: 35073694
Externally is resolving the site using the WAN IP address but the name. In the register.com I have the right WAN IP address.

internally it resolves no problem using either the private or external IP address.
0
 
LVL 30

Assisted Solution

by:Brad Howe
Brad Howe earned 1600 total points
ID: 35073720
It is not the IP address i am questioning. It's your DNS setup.

Please confirm your IIS bindings and NSLOOKUP results.

cheers,
Hades666
0
 

Author Comment

by:marceloNYC
ID: 35074322


The Site Bindings are:Type http  port 80   IP Address *   hostename empty

the telnet did not work...

 NSLOOKUP the router the internal IP address of the AT&T device is responding to the localhost.



0
 
LVL 30

Assisted Solution

by:Brad Howe
Brad Howe earned 1600 total points
ID: 35074714
What is your domain address? Let me check this externally.

You can also (FOR TEST PURPOSES) add xxx.xxx.xxx.xxx your.domain.com to your local host file and test.

- Hades666
0
 

Author Comment

by:marceloNYC
ID: 35074749
zulutek.com

Thanks!
0
 

Author Comment

by:marceloNYC
ID: 35074757

      99.183.193.79 WAN IP
0
 
LVL 30

Assisted Solution

by:Brad Howe
Brad Howe earned 1600 total points
ID: 35074775
You domain is not registered properly.

> zulutek.com
Server:  UnKnown
Address:  192.168.1.1

*** No address (A) records available for zulutek.com
>

if http://Wan.Ip.addr resolves then the site is setup properly. You just need to create the A record on your register now.

cheers,
Hades666
0
 

Author Closing Comment

by:marceloNYC
ID: 35074923
Thank you guys!!! I got rusty after so many years out of the field.
0

Featured Post

Survive A High-Traffic Event with Percona

Your application or website rely on your database to deliver information about products and services to your customers. You can’t afford to have your database lose performance, lose availability or become unresponsive – even for just a few minutes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question