Avatar of Scott McDaniel (EE MVE )
Scott McDaniel (EE MVE )
Flag for United States of America asked on

0x800702e4 Error in VB.NET application

I'm working on a project in Visual Studio 2010, running on my Windows 7 64 bit workstation. In that project, I've included a COM reference to a .exe file provided by a 3rd party. This .exe file provides an interface to a database (it's basically an SDK that accepts XML requests and provides responses). In order to use it, you write code like this:

Dim MyObj As New MyInterface.MyRequestProcessor

This is documented in the "guide" provided with the SDK (note: That "guide" is basically worthless, as is the "support" from the development team for the SDK).

The code above immediately errors out during a debug session with the following error:

System.Runtime.InteropServices.COMException (0x800702E4): Retrieving the COM class factory for component with CLSID {xxxx-xxxxxx-xxx} failed due to the following error: 800702e4 at Project.clsQuote.AddQuote() in C:\Users\MyName\documents\visual studio 2010\Projects\folderName\Subfolder\clsAddQuote.vb:line 217"

The error translates over to "requested operation requires elevated permissions".

I have turned OFF UAC on the machine, but the error persists. I've set the .exe file to run in Compatibility mode, and I've set it to run with Administrator Privileges. I've tried toggling the CopyLocal and Isolated properties of the reference.

The error persists regardless of what I do.

Am I missing something, or am I just out of luck with getting this to run on my machine?


.NET ProgrammingVisual Basic.NETProgramming

Avatar of undefined
Last Comment
BurnieP

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
BurnieP

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Scott McDaniel (EE MVE )

ASKER
That seems to have done the trick (i.e. setting the "deven.exe" file to run as Administrator). Oddly enough, I read that post but failed to notice the mention of running as Administrator.

I've been wrangling with this off-and-on for about a week now, so I'm sure glad to get this resolved. Thanks for your prompt response!
Scott McDaniel (EE MVE )

ASKER
Excellent advice, couldn't ask for better service from EE.
BurnieP

I am glad that I could help you LSM.  You have made my day with your great comment.  Thank you!
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes