SBS 2008 Loses Network Connectivity Every Week

I have a new SBS 2008 setup in a small office environment that acts as DC, DNS server, and DHCP server (along with serving Quickbooks Accounting and Point of Sale). Every 7 to 8 days, I lose the network connection on it. My RMM agent that is installed will lose connection with my server and generate an alert that the server is offline. Connecting remotely will not work, connecting via RDC from another network computer will not work. Pinging the server from another computer on the network does return a response (I will have to confirm this next time, but I am almost certain).

There do not seem to be any error logs that apply. I thought it was due to a persistent DCOM error I was getting before (Network services permission issue), but I took care of that last week, and still had the server go down early yesterday morning.

This one is really baffling me. As a side note, we do not use Sharepoint, but being SBS, it is installed. Could this be a DNS or DHCP issue?

Thanks!
Chip
CreeksidetechAsked:
Who is Participating?
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
If you restart the DNS server service, does everything start working again?

I had a similar problem and adding DNS forwarders solved that for me.

Are you also ip-to-date with Service Packs / Rollups for the server / Exchange?
0
 
The_Dark1Commented:
What networking device are you using?
It could be your network device reseting its ARP tables, when it does this, you will tend to loose network connectivity from the attached devices.

Read the logs on your network devices (Cisco, Netgear) you might gain insight on that is happening there.
0
 
orjan_erikssonCommented:
Do you have broadcom NICs on your server?

Does a reebot fix the problem temporarily?

If so i might help since i have experienced these problem on several Dell servers that are using Broadcom NIC's. In my cases what happens is that the network connection halts and one after another the services fail and when AD dies everything goes sour.

The fix was to upgrade to the latest firmware and the latest drivers for the NIC's.

/Orjan
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
CreeksidetechAuthor Commented:
Sorry for the delay everyone - thanks for all the input.

Alan, I checked the DNS forwarders tab, and sure enough, there was only one entry for the gateway (I run an Untangle router/firewall). I added the ISP's two DNS servers, but should I take the entry for the gateway out? It does not resolve. There is probably a setting on the router to forward the DNS info it gathers through to the server, but since I put it in manually, that would be redundant.

I did not have a chance to try and restart the DNS manually as I have only had remote access when this server goes down, and that does nobody good when the problem is the network... Just had staff manually restart.

I will give it several days to see if the problem reappears.

The Dark: Good thought on the ARP tables, but I looked at the logs and things seem normal.

Orjan: There are only Intel NICs in this server, but a reboot does fix the problem for 7-9 days.

Thanks again everyone - fingers crossed!
0
 
Rob WilliamsCommented:
Do you have the SBS VPN configured? If so to ad to Alan's DNS suggestions I have seen a VPN connection affect DNS and loss of server access. If it is enabled, in the DNS management console under properties for the server, under the Interfaces tab make sure only the Server's LAN IP for IPv4 & IPv6 are checked. In other words make sure the VPN/PPP adapter's IP is not checked.
Also in the network connections widow, on the menu go to advanced settings and under adapters and bindings, make sure the LAN connection is at the top of the list.

Two other thoughts;
-I trust you have not disabled IPv6? Do not on SBS 2008.
-You mentioned "There are only Intel NICs ". You can only have one NIC with SBS 2008. All others must be disabled, not just disconnected.
-Have you run the BPA? It is very good at pointing out configuration issues.
http://www.microsoft.com/downloads/en/details.aspx?familyid=86a1aa32-9814-484e-bd43-3e42aec7f731&displaylang=en

0
 
Alan HardistyCo-OwnerCommented:
If the IP doesn't resolve, then remove the IP and replace them with working IP's for your ISP's DNS servers, but I would first restart the DNS Server Service to see if you can prove it is DNS that is the problem.

Alan
0
 
questlCommented:
I had an similar issue. I was not able to connect to the internet after 6 to 7 days. A reboot resolved it, but it reappeard. The reason was a wrong configured MTU Size in our router. Instead of MTU 1500 it was 1429 or so. After changing the MTU size back to 1500 for the internal network, everything was fine again

0
 
Rob WilliamsCommented:
Interesting that change would help. Generally lowering MTU will decrease performance but increase stability. Keep in mind some services require lower MTU's. In particular PPPoE DSL 1492, and then also, but does not apply here; VPN's such as L2TP 1460 & PPTP 1430.
0
 
CreeksidetechAuthor Commented:
So far so good - everything seems to be going smoothly. I'm going to give it a few more days before I call it solved.

Rob, I referenced NICs, and the motherboard has two built in. I did completely disable the one that is not being used, and have left IPv6 enabled. I do have the BPA installed, and everything tests fine there.

Alan, when the server has gone down in the past, I have been unable to physically be there in front of it before it needs to be back up, and from the same experience several weeks in a row, a quick press of the reset button from one of the staff has it back up and running for about a week. I wish I could confirm that it was a DNS service issue...

Quest, that is odd - I have only LOWERED MTU to fix problems. What kind of router were you using?
0
 
Alan HardistyCo-OwnerCommented:
Sounds good.  So have you just added forwarders so far?  Have you done something else too?
0
 
CreeksidetechAuthor Commented:
For this iteration, I have just added the forwarders at this point. Prior to posting the question, I took care of the DCOM issue and a couple of others, thinking that could be contributing, but the problem remained.
0
 
Alan HardistyCo-OwnerCommented:
0
 
CreeksidetechAuthor Commented:
Adding the DNS forwarders seems to have fixed the issue - Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.