• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4518
  • Last Modified:

LACP between Cisco and HP procurve

The networked is depicted in the diagram.  The 172 network is a SAN.  I'd like to use 4 ports from the Cisco 3020 to the HP 2810 as a port-channel so as to take advantage of more bandwidth.  So far I have not has luck getting the channel to come up or stay up.  I plugged 4 cables from Cisco to HP, made sure they were in the correct vlan, setup the ports on the HP switch into a trunk:

Conf t
Int 1-4
lacp
Exit
Trunk 1-4 trk1 trunk lacp

On cisco setup a port channel, added the ports to it and then ran this on the ports:

Channel-group 1 mode passive

I thought that would make the HP 2810 setup a port trunk with the cisco but it generally brought down the network, caused flapping errors on the cisco and caused the ports to go up and down.  

Visio-Drawing1.jpg
0
dmwynne
Asked:
dmwynne
  • 2
  • 2
  • 2
1 Solution
 
cdowdyCommented:
Are you aggregating Vlan 5, the upper 3020 in your drawing, or Vlan 1?
0
 
cdowdyCommented:
Oh, wait, I see the ports outlined in your diagram. So the lower 3020 in Vlan1 will have the LACP aggregation.. I just wanted to make sure you were sending LACP frames untagged on VLAN1.
0
 
Don JohnstonInstructorCommented:
Are you running LACP mode active on the HP? If you're not, then you would have to use active mode on the Cisco.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
dmwynneAuthor Commented:
Both 3020 will run lacp aggregation to the hp 2810.

I thought hp ran lacp in active by default and it seemed that the channel was formed but it would immediately go down and the ports were flapping.  ON the cisco side I had the channel-group in passive mode.
0
 
Don JohnstonInstructorCommented:
Would try the Cisco in active mode just to be sure.

But if it comes up and then starts flapping, that's probably not the issue.

Sounds more like a configuration mismatch. Double check the settings of all ports for speed, duplex, trunking/tagging, allowed vlans, etc.
0
 
dmwynneAuthor Commented:
I had the hp side setup using the wrong protocol.

I had it setup as Trunk 1-4 trk1 trunk lacp

What i need was to setup each interface with

lacp active

On the cisco setup with


 switchport mode access
 channel-protocol lacp
 channel-group 1 mode passive
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now