Link to home
Create AccountLog in
Avatar of smartinez1984
smartinez1984

asked on

VLAN Tagging on Cisco 2924 Switch

I am trying to troubleshoot a device connectivity issue which consists of a CPE which tags traffic on it's WAN interface with VLAN 35. I can see the tag in a Wireshark capture. According to the vendor, I need to configure the switch to tag the traffic on VLAN 35 for the WAN interconnect & then strip the VLAN tag on the interface that will send traffic outbound from the switch. So, basically, CPE WAN port connects to tagged port on the 2924 (port 1) and then traffic leaving the switch on port 13 will strip the tag. I've been trying to get this working but just having a whale of a time.

If I do a packet capture I see the DHCP requests with an 802.1Q section with the ID of 35.

Any ideas? The switch is running older code - 12.0(5.4).

The engineer for the device followed up with this:

"Cisco2924 should work for this.

Setup one port on 2924 as 802.1Q Trunking port and connect it to R1000H WAN Ethernet.

Setup one port on 2924 with ingress VLAN tag 35 (egress traffic shouldn’t have any VLAN) and connect it to HDM."

I can setup the 802.1Q trunking port - what exactly is the configuration for the other ingress port?

Thanks,

-Samson
ASKER CERTIFIED SOLUTION
Avatar of Les Moore
Les Moore
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of smartinez1984
smartinez1984

ASKER

Well, no...

Basically, here is the situation. The CPE is broadcasting for a DHCP address. However, the device is also tagging the frames with VLAN 35 ID.

The vendor is saying we have to tag the inbound interface by using a DOT1Q trunk. However, the outbound interface, while configured as an access port on VLAN 35, has to strip the tag.

That's where i'm having difficulty. I've tried creating the outbound interface with the native VLAN assigned as 35 but packet captures upstream still show the tag applied. Which apparently causes problems.

So, in a nutshell, I need to have the port that connects to the CPE as a DOT1q trunk and the outbound interface on the same switch has to strip the tag.

-Samson
Got it working. Configured the CPE interconnect as a trunk:

switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast

Then configured the outbound interface (connecting to upstream switch) as follows:

switchport access vlan 35

So, yea, right track... :)