Avatar of dpsaxman
dpsaxman
 asked on

Exchange proxy server Cert error

This is the error msg I get when trying to open Outlook when I am remote . This happens to all of my remote users.  This happens after you VPN in and open Outlook. Once you hit OK and Outlook works fine.

Outlook-error-with-VPN.pdf
Outlook

Avatar of undefined
Last Comment
Alan Hardisty

8/22/2022 - Mon
Alan Hardisty

That's because your certificate is named srvexchange and not mail.yourdomain.com

Either regenerate your self signed certificate with the correct name in it or buy a 3rd party SSL certificate and install that instead.

What version of Exchange and is it part of SBS?

Alan
dpsaxman

ASKER
Thanks Alan, that is a good tip. It is Exchange 2007 and it is on server 2003-R2.
Alan Hardisty

Okay - not a problem.

With Exchange 2007 you really need a SAN / UCC certificate to make all the features of Exchange work easily.  It can be done without - but I'm not aware of the settings to tweak to get that working.

If you get a SAN / UCC certificate , please make sure you add the following names:

mail.domain.com
autodiscover.domain.com
srvexchange.internaldomain.local
srvexchange

Cheapest place is probably GoDaddy or a GoDaddy Reseller account might be cheaper still.

If you don't want to buy a certificate - then you can install the Windows 2003 certificate Services and issue your own certificate (single name).
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
dpsaxman

ASKER
Thank you sir, I will give some of these choices a try. The last (2) solutions you gave I feel are spot on.
Thank you Alan.
ASKER CERTIFIED SOLUTION
Alan Hardisty

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.