• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1087
  • Last Modified:

How do I stop Word 2007 from creating gray brackets / OLE bookmarks when copying?

Hey all.

Been trying to figure this out, and have been scouring the Internet looking for a solution, to no avail.  Here's the deal.  Every time I use Control + C to copy text in Word 2007, the program puts these grey brackets around them.  I did some research, and found out that these were OLE bookmarks.  They can be deleted manually, or via macro, but I don't want to have to keep deleting bookmarks that I didn't want in the first place.  These documents are edited by about a dozen people who copy and paste freely.  The bookmarks are creating a ton of clutter.

I know that there's an option to hide these bookmarks, but that's not doable.  We actually do use the bookmark function for legit, manually placed bookmarks.

I have noticed that this behavior is not universal.  There are some computers on which it doesn't occur.  Yet, I cannot see any difference, so I cannot figure out why.  

Anybody have any ideas?
0
RayAdverb
Asked:
RayAdverb
1 Solution
 
GrahamSkanCommented:
Is it just the visibility of the bookmarks that is the problem? The default is not to see them, and it is possible to use bookmarks without keeping them visible.

You could run a small macro periodically to delete them.
Sub DelOLEBookmarks()
    Dim bmk As Bookmark
    For Each bmk In ActiveDocument.Bookmarks
        If InStr(1, bmk.Name, "OLE_LINK", vbTextCompare) = 1 Then
            bmk.Delete
        End If
    Next bmk
End Sub

Open in new window

0
 
RayAdverbAuthor Commented:
Graham,

It's kinda hard to explain.  We're using the bookmarks not so much as jumping points within the document (as you would bookmarks when, say, reading an Ebook), but as demarcation points between separate areas of text.  

I've seen the macro you're referring to, and while it'd work as a nice after the fact when one person is finished working with these documents, it'd get cluttered up again when the next person starts copying and pasting.

If there is absolutely no way to disable the bookmarks from being created, I'll accept that and we can figure out a workaround (I'm thinking forego Ctrl + C for copying and instead use Ctrl + X plus Ctrl + V for the same overall effect but without the bookmarks being added).
0
 
cblappCommented:
Are these pieces of text being copied from another document or another program?  What process are they using to place it in the new document?  It sounds like they are using a "Paste Special" command, which would create a link to the original location.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now