How can I stop (XP Pro) IE8 from claiming itself to be the default browser ?

I noticed a few days ago that, suddenly, IE8, which I rarely use, was popping up as the default browser whenever I clicked on an email containing a link to a website.  I have tried the tick to "Tell me if Internet Explorer is not the default browser" several times but it makes no difference.

I have been using the Avant browser for many years and am familiar with it and I find IE very annoying and relatively slow.
Who is Participating?
☠ MASQ ☠Connect With a Mentor Commented:
Sorry - you said you did that already!
You need to change the setting in Avant (or if that doesn't work in the registry)
See this link
☠ MASQ ☠Commented:
Tools > Internet Options > Programs Tab
Uncheck the first option on that page.  Then get your favorite browser set as default
dlznetAuthor Commented:
Thank you - I did look there a few days ago but I missed it for some reason - probably panic!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.