Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Linux Default Permissions

Posted on 2011-03-07
8
Medium Priority
?
369 Views
Last Modified: 2012-09-13
Somehow my linux box has setting for new directorys and files to set it at 700 and 600... I have tried umask, but the best I can do is 775
0
Comment
Question by:PrattCC1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 23

Expert Comment

by:Maciej S
ID: 35059276
umask is the right tool.
What permissions you want to have, and what is you umask setting now?
0
 
LVL 14

Expert Comment

by:Deepak Kosaraju
ID: 35059280
what was your question? can you make the question more informative.
0
 

Author Comment

by:PrattCC1
ID: 35059602
the umask setting do not reset... I want the normal 0022 if I set it to 0022 I get a folder set to 700 and files set to 600

If I set it to 0000 sometimes its 775
0
Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

 
LVL 31

Expert Comment

by:farzanj
ID: 35061493
This is typically how it works -- a little off though.

Here is a reference for you
http://www.cyberciti.biz/tips/understanding-linux-unix-umask-value-usage.html

So if you set umask to 002, the default permissions should be 777-002 = 775 for folders and 666 - 002 = 664 for files.
0
 

Author Comment

by:PrattCC1
ID: 35062320
I get that, I have mine set to 002 however when I create a new folder it is 700
0
 
LVL 31

Expert Comment

by:farzanj
ID: 35064120
What type of Linux box do you have?  What version?  Do you have SELinux enabled?
0
 

Author Comment

by:PrattCC1
ID: 35068501
Fedora 12 64bit no SELinux
0
 
LVL 13

Accepted Solution

by:
Sandy earned 1500 total points
ID: 38140875
#umask 0022

this will solve your prob and put permission to defaults.

Dir => 0755
File => 0644
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After running Ubuntu some time, you will be asked to download updates for fixing bugs and security updates. All the packages you download replace the previous ones, except for the kernel, also called "linux-image". This is due to the fact that w…
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question