• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 484
  • Last Modified:

Sharepoint 2010 "My Site" Initial Page Locale Issues

Hi Experts.
I have looked all over for this, with no success.
We're testing Sharepoint Server Enterprise 2010.  Everything works as expected with just one exception. When users navigate to their "My Site", dates are showing up in US format.  Additionally, users will have to manually go into their site settings and change the locale from US to UK to get date and time settings to show up correctly in their document libraries etc.
Is there an easy way to default the "My Site" to show everything in UK Locale?  I've checked the server (2008 R2 SP1 64Bit), and the locales are set correctly.
Thanks
Dave
0
djparker1969
Asked:
djparker1969
1 Solution
 
KoenVostersCommented:
You will need to add a feature stapler to the site definition:
http://www.parallelfun.com/post/2010/12/22/Configure-Language-Region-Sharepoint-2010.aspx

In that feature receiver you'll need to put code that resembles this:
mySiteWeb.RegionalSettings.LocaleId = (numberforUKlocale);
mySiteWeb.RegionalSettings.Time24 = true;

mySiteWeb.Update();

0
 
djparker1969Author Commented:
Microsoft don't make it easy!  But thanks for the reply.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now