Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Understanding Cisco Route-Maps used at default gateway

Posted on 2011-03-07
5
Medium Priority
?
703 Views
Last Modified: 2012-06-21
HI,

I'm wondering if you could enlighten me in regards to Cisco Route-Maps. I've used them many times in the past with success, but never used them to handle the default gateway. In essence, I would like two default gateways. One for 5 specific source IP's to go out one way. The second would be a catch all to send everyone else out the second gateway. Is this possible? I tried the configuration below, but had a static ip route 0.0.0.0 in the mix still and the route-maps didn't work at all. The counts did go up on the route-maps when I did a 'show ip access-list'. Also, are route maps executed in the order of their sequence number? Do you think the below will work?

*below is a excerpt of my configuration. I only included the information I thought was necessary to setup proper router maps*

interface FastEthernet0/1
description Local LAN interface
ip policy route-map external

access-list 190 permit ip host 10.35.209.20 any
access-list 190 permit ip host 10.35.209.21 any
access-list 190 permit ip host 10.35.209.22 any
access-list 190 permit ip host 10.35.209.23 any
access-list 190 permit ip host 10.35.209.24 any
access-list 191 permit ip host any any

route-map external permit 190
 match ip address 190
 set ip next-hop 1.2.3.4

route-map external permit 191
 match ip address 191
 set ip next-hop 4.3.2.1

Thank you!
0
Comment
Question by:First Last
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 2000 total points
ID: 35059657
Hi,

you need to add route:

no route-map external permit 191
ip route 0.0.0.0 0.0.0.0 4.3.2.1


CTRL + Z

clear ip ip cef *
0
 
LVL 1

Author Comment

by:First Last
ID: 35059903
You are saying the route-map is executed before a static route?

So, my overall config would be:

interface FastEthernet0/1
description Local LAN interface
ip policy route-map external

access-list 190 permit ip host 10.35.209.20 any
access-list 190 permit ip host 10.35.209.21 any
access-list 190 permit ip host 10.35.209.22 any
access-list 190 permit ip host 10.35.209.23 any
access-list 190 permit ip host 10.35.209.24 any

route-map external permit 190
 match ip address 190
 set ip next-hop 1.2.3.4

ip route 0.0.0.0 0.0.0.0 4.3.2.1

0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 35059970
yep!
0
 
LVL 1

Author Closing Comment

by:First Last
ID: 35060304
I'll test the changes tomorrow night. Thank you.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 35060354
your welcome.....:)
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question