No Rule to Make Target

Posted on 2011-03-07
Last Modified: 2012-05-11
Hello, I am a newbie to Linux. I need to install a program called MassAdmin so I can find out all the mounts on every linux box without visiting every box. I have installed all the prereq. packages except Net-Ping-2.36. When I try to install it I get  **** No rule to make target 'realclean". Stop

What am I doing wrong? I used Yum to download the tarball massadmin wich included the packeages net-ping,etc. I amd using gcc as well. I hope that helps. I am new to this so please give full commands when answering if possible and assume I dont know anything about linux. Thanks in advance.
Question by:Bryant
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2

Expert Comment

ID: 35062292
Did you tried to do ./Configure ?
LVL 12

Expert Comment

ID: 35065298
The command should be as given below.



make install

But I will suggest you an important thing for installing software from tar balls or zip files. After untar or unzip the file go in that directory and find file name README and INSTALL, you will find complete instruction in these files to install that particular software.

Above I have suggested the standard proceedure but I might be different with your software so the best way is to refer package's INSTALL or README file.

Author Comment

ID: 35068676
this is directly from the Read Me file. i have been following all of the read me instruction because I am just learning what I am suppose to be doing.

    The latest source tree is available via cvs:

      cvs -z3 -q -d checkout Net-Ping
      cd Net-Ping

    The tarball can be created as follows:

      perl Makefile.PL ; make ; make dist

    The latest Net::Ping release can be found at CPAN:


    1) Extract the tarball

      gtar -zxvf Net-Ping-xxxx.tar.gz
      cd Net-Ping-xxxx

    2) Build:

      make realclean
      perl Makefile.PL
      make test

    3) Install

      make install

    Or install it RPM Style:

      rpm -ta SOURCES/Net-Ping-xxxx.tar.gz

      rpm -ih RPMS/noarch/perl-Net-Ping-xxxx.rpm

At what directory should I do ./configure because I just got an error saying "No Such File or Directory"
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

LVL 12

Expert Comment

ID: 35068714
Go to the directory where you have extracted the Net-Ping.

cd Net-Ping-xxxx

Then execute the below given commands one by one to build.

make realclean
      perl Makefile.PL
      make test

After executing these commands execute below given command to install.

make install

Author Comment

ID: 35068746
I am in Net-Ping-2.36 directory
 I type

make realclean

I get

*****No rule to amke target 'realclean'. Stop

Accepted Solution

Bryant earned 0 total points
ID: 35070753
Ok, I got it to work.

make clean

 works......... but

 make realclean ..........doesnt..

thanks for everyone that tried....

Author Closing Comment

ID: 35120633
this worked great.

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Join Greg Farro and Ethan Banks from Packet Pushers ( and Greg Ross from Paessler ( for a discussion about smart network …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question