Solved

interVLAN routing not functioning on cisco 3750

Posted on 2011-03-07
23
706 Views
Last Modified: 2012-05-11
For some reason I can't ping any other VLAN from within my cisco 3750 switch from within a hyperterminal session, let alone an external device connected to a switch. THe only VLAN I can ping is vlan1 and vlan103.  Why is that? I can't pinpoint when the problem started appearring.

see my config below:

spanning-tree mode rapid-pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan internal allocation policy ascending
!
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet3/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet3/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet3/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet3/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet3/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet3/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet3/0/9
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/10
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/11
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/12
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/13
 speed 100
 duplex full
!
interface FastEthernet3/0/14
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/15
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/16
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/17
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/18
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/19
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/20
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/21
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/22
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/23
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/24
 speed 100
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet3/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface Vlan1
 ip address 10.100.20.4 255.255.255.0
 standby 1 ip 10.100.20.2
 standby 1 preempt
!
interface Vlan100
 ip address 10.100.2.4 255.255.255.0
 standby 100 ip 10.100.2.2
 standby 100 preempt
!
interface Vlan101
 ip address 10.100.22.4 255.255.255.0
 standby 101 ip 10.100.22.2
 standby 101 preempt
!
interface Vlan102
 ip address 10.100.23.4 255.255.255.0
 standby 102 ip 10.100.23.2
 standby 102 preempt
!
interface Vlan103
 ip address 10.100.24.4 255.255.255.0
 standby 103 ip 10.100.24.2
 standby 103 preempt
!
interface Vlan104
 ip address 10.100.25.4 255.255.255.0
 standby 104 ip 10.100.25.2
 standby 104 preempt
!
interface Vlan105
 ip address 10.100.26.4 255.255.255.0
 standby 105 ip 10.100.26.2
 standby 105 preempt
!
interface Vlan106
 ip address 10.100.27.4 255.255.255.0
 standby 106 ip 10.100.27.2
 standby 106 preempt
!
interface Vlan107
 ip address 10.100.28.4 255.255.255.0
 standby 107 ip 10.100.28.2
 standby 107 preempt
!
!
router eigrp 100
 redistribute connected
 redistribute static
 network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.100.2.253
ip http server
ip http secure-server
!
!
!
snmp-server community isicontrols! RW
snmp-server community isi RO
!
control-plane
!
!
line con 0
line vty 0 4
 transport input ssh
line vty 5 15
 transport input ssh
0
Comment
Question by:adimit
  • 9
  • 9
  • 4
  • +1
23 Comments
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 323 total points
Comment Utility
Hi,

Did you enabled 'ip routing' ?
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
please provide us:
sh ip int brief
0
 

Author Comment

by:adimit
Comment Utility
its not in the attched config but its the first line of the actual config:

how ip int brief
Interface              IP-Address      OK? Method Status                Protocol

Vlan1                  10.100.20.4     YES NVRAM  up                    up

Vlan100                10.100.2.4      YES NVRAM  down                  down

Vlan101                10.100.22.4     YES NVRAM  down                  down

Vlan102                10.100.23.4     YES NVRAM  down                  down

Vlan103                10.100.24.4     YES NVRAM  up                    up

Vlan104                10.100.25.4     YES NVRAM  down                  down

Vlan105                10.100.26.4     YES NVRAM  down                  down

Vlan106                10.100.27.4     YES NVRAM  down                  down

Vlan107                10.100.28.4     YES NVRAM  down                  down

GigabitEthernet1/0/1   unassigned      YES unset  down                  down

GigabitEthernet1/0/2   unassigned      YES unset  down                  down

GigabitEthernet1/0/3   unassigned      YES unset  down                  down

GigabitEthernet1/0/4   unassigned      YES unset  down                  down

GigabitEthernet1/0/5   unassigned      YES unset  down                  down

GigabitEthernet1/0/6   unassigned      YES unset  down                  down

GigabitEthernet1/0/7   unassigned      YES unset  down                  down

GigabitEthernet1/0/8   unassigned      YES unset  down                  down

GigabitEthernet1/0/9   unassigned      YES unset  down                  down

GigabitEthernet1/0/10  unassigned      YES unset  down                  down

GigabitEthernet1/0/11  unassigned      YES unset  down                  down

GigabitEthernet1/0/12  unassigned      YES unset  down                  down

GigabitEthernet2/0/1   unassigned      YES unset  down                  down

GigabitEthernet2/0/2   unassigned      YES unset  down                  down

GigabitEthernet2/0/3   unassigned      YES unset  down                  down

GigabitEthernet2/0/4   unassigned      YES unset  down                  down

GigabitEthernet2/0/5   unassigned      YES unset  down                  down

GigabitEthernet2/0/6   unassigned      YES unset  down                  down

GigabitEthernet2/0/7   unassigned      YES unset  down                  down

GigabitEthernet2/0/8   unassigned      YES unset  down                  down

GigabitEthernet2/0/9   unassigned      YES unset  down                  down

GigabitEthernet2/0/10  unassigned      YES unset  down                  down

GigabitEthernet2/0/11  unassigned      YES unset  down                  down

GigabitEthernet2/0/12  unassigned      YES unset  down                  down

FastEthernet3/0/1      unassigned      YES unset  down                  down

FastEthernet3/0/2      unassigned      YES unset  down                  down

FastEthernet3/0/3      unassigned      YES unset  down                  down

FastEthernet3/0/4      unassigned      YES unset  down                  down

FastEthernet3/0/5      unassigned      YES unset  down                  down

FastEthernet3/0/6      unassigned      YES unset  down                  down

FastEthernet3/0/7      unassigned      YES unset  down                  down

FastEthernet3/0/8      unassigned      YES unset  down                  down

FastEthernet3/0/9      unassigned      YES unset  up                    up

FastEthernet3/0/10     unassigned      YES unset  up                    up

FastEthernet3/0/11     unassigned      YES unset  down                  down

FastEthernet3/0/12     unassigned      YES unset  down                  down

FastEthernet3/0/13     unassigned      YES unset  down                  down

FastEthernet3/0/14     unassigned      YES unset  down                  down

FastEthernet3/0/15     unassigned      YES unset  down                  down

FastEthernet3/0/16     unassigned      YES unset  down                  down

FastEthernet3/0/17     unassigned      YES unset  down                  down

FastEthernet3/0/18     unassigned      YES unset  down                  down

FastEthernet3/0/19     unassigned      YES unset  down                  down

FastEthernet3/0/20     unassigned      YES unset  down                  down

FastEthernet3/0/21     unassigned      YES unset  down                  down

FastEthernet3/0/22     unassigned      YES unset  down                  down

FastEthernet3/0/23     unassigned      YES unset  down                  down

FastEthernet3/0/24     unassigned      YES unset  down                  down

GigabitEthernet3/0/1   unassigned      YES unset  up                    up

GigabitEthernet3/0/2   unassigned      YES unset  up                    up

Port-channel1          unassigned      YES unset  up                    up
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
It seems that all VLANs down, ....
Did you created this vlans?

Please provide us " sh vlan"
0
 

Author Comment

by:adimit
Comment Utility
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/1, Gi1/0/2, Gi1/0/3
                                                Gi1/0/4, Gi1/0/5, Gi1/0/6
                                                Gi1/0/7, Gi1/0/8, Gi1/0/9
                                                Gi1/0/10, Gi1/0/11, Gi1/0/12
                                                Gi2/0/1, Gi2/0/2, Gi2/0/3
                                                Gi2/0/4, Gi2/0/5, Gi2/0/6
                                                Gi2/0/7, Gi2/0/8, Gi2/0/9
                                                Gi2/0/10, Gi2/0/11, Gi2/0/12
                                                Fa3/0/1, Fa3/0/2, Fa3/0/3
                                                Fa3/0/4, Fa3/0/5, Fa3/0/6
                                                Fa3/0/7, Fa3/0/8, Fa3/0/13
                                                Fa3/0/14, Fa3/0/15, Fa3/0/16
                                                Fa3/0/17, Fa3/0/18, Fa3/0/19
                                                Fa3/0/20, Fa3/0/21, Fa3/0/22
                                                Fa3/0/23, Fa3/0/24
103  VLAN0103                         active
1002 fddi-default                     act/unsup
1003 trcrf-default                    act/unsup
1004 fddinet-default                  act/unsup
1005 trbrf-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
103  enet  100103     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0


VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 141 total points
Comment Utility
Most likely reason is that you don't have any functional physical ports carrying those VLANs. Until you do, the SVI's for those VLANs will be in a down state.

0
 

Author Comment

by:adimit
Comment Utility
as can be seen by the ip int brief I do have functioning physical ports
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
you need to add vlans:

CTRL+Z
vlan data
Vlan100
Vlan101
Vlan102
Vlan104
Vlan105
Vlan106
apply
exit


Vlan107                10.100.28.4     YES NVRAM  down                  down
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
and you need to add vlan 107:

vlan data
Vlan107
apply
exit
0
 
LVL 3

Assisted Solution

by:mrmozaffari
mrmozaffari earned 36 total points
Comment Utility
It seems you have problem to define Vlan :

Although you have some ports in up state but those are only (Fast 3/0/9 and 3/0/10) which has assigned to Vlan 100 ,Vlan 100 also is down ,it seems you didn't define it correctly ,you have config it as the way "Ikalmar" said in previous comment ,remember you configured this vlan as standby ,also you need to issue  "ip routing" command in configuration mode.
I think you created your vlans just with this command "interface vlan xxx" ,and then "no shutdown" ,
you have to do like this :

Switch# Configure terminal
switch(config)# vlan 107
apply
exit
 

0
 

Author Comment

by:adimit
Comment Utility
i delete and create new vlans. no effect
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 

Author Comment

by:adimit
Comment Utility
how does the vlan.dat file get written to. that file size never changes as I add and remove vlans
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
please show:

sh vtp status
sh vlan
sh ip int brief
0
 

Author Comment

by:adimit
Comment Utility
could my problem be a mismatch between that file and my running-config?
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
if the switch vlan table not contains the vlan interfacfaces SVIs they never come up!
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 141 total points
Comment Utility
>could my problem be a mismatch between that file and my running-config?

No.

please post the output of a "show vtp status" and "show vlan"
0
 

Author Comment

by:adimit
Comment Utility
show vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
ok int his case (it is a vtp server) you need to add the VLANs to vlan database:

CTRL+Z
vlan data
Vlan100
Vlan101
Vlan102
Vlan104
Vlan105
Vlan106
Vlan107  
apply
exit

wri mem


   

0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 141 total points
Comment Utility
>i delete and create new vlans. no effect

Are the VLANs being created? What I mean is, after you create the VLAN, do they show up with a "show VLAN" command?

Or do they never get added to the VLAN database?

If they aren't, do you receive a message when you attempt to create them?
0
 

Author Comment

by:adimit
Comment Utility
they don't show up with a show VLAN. I never get a message indicating anything wrong.
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 141 total points
Comment Utility
Can you post the session so we can see what's being typed and the response.
0
 

Author Comment

by:adimit
Comment Utility
any way tKalmar's last comment worked. Don't understand why I have to this but all of my vlan interfaces are up
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 323 total points
Comment Utility
if your switch VLAN database not contains the VLAN SVIs it never comes up!
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Cisco MSRP pricing 5 45
Cisco Routing / Question on LACP 14 75
Which Cisco Switch is right for us, 10 46
HSRP needed? 4 25
I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now