Avatar of GaryGarland
GaryGarland
 asked on

Remote Desktop can not connect to single client

Hi All,
I know enough to be dangerous.  I did search for the issue, can't find the solution.
Server SBS 2008, Windows 7 Pro, remote desktop connection not working for individual machine, works for others. I can ping the machine.
Was able to remote into the server from home, and from the server opened new window and attempted to remote to unhappy client machine - no joy - i get the error ""VBScript Remote Desktop Disconnected - The computer that you are trying to connect to cannot be contacted.  Verify that it is turned in, is awake, and is connected to the network."
Yeah, it's on, in fact, i'm typing on it!  
It had PREVIOUSLY worked, and I've experienced issues like this before, with the solution being a reformat - something I'd like to avoid.  I'm guessing it's a microsoft update that affected settings somewhere, or else an app I've added.
Remote Desktop is enabled (technically, greyed under enabled).    I've fooled around with the registry, with 0 and 1 for fenytsconnections (the default had been 1, i changed to 0 and rebooted, yet ironically, a notebook which works fine under my credentials had the settings as 1 - and in fact, it warned me (in rdp) to enable windows firewalll to allow rdp!!!!!) - i've since disabled windows firewall entirely (and vipre's firewall) - i'm behind a sonicwall appliance anyway - but even with the vipre firewall i could remote into the other clients.
i'm an admin - both doman and local machine.
i've tried being more broad with the group policies (a place i'm not that comfortable mucking around in)
i've seen some VBscripts floating around - i don't even know how to run (i tried making them batch files - that didn't work)
any help appreciated - but almost as much, why just one machine?  thanks so much!
Windows 7Remote AccessSBS

Avatar of undefined
Last Comment
GaryGarland

8/22/2022 - Mon
mattclarified

Try this guide for allowing a port access through the firewall on the machine you are connecting to.  The port you need to open is 3389

http://maximumpcguides.com/windows-7/open-a-port-in-windows-7s-firewall/

M@
dlan75

Hi,
make sure NAT is properly configured on the sonicwall
make sure you have selected a proper user to access that computer using RDP.
try reinstalling the rdp client http://www.mydigitallife.info/2009/11/01/download-remote-desktop-connection-7-0-client-to-connect-to-windows-7-and-server-2008-r2-with-full-features/
SysExpert

Since it did work before, I would definitely see if you can uninstall any MS updates, and reapply as needed. maybe the last RDP will show up in a log or event log so that you can pin down which MS updates came after

I hope this helps !

I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER CERTIFIED SOLUTION
GaryGarland

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
GaryGarland

ASKER
hi - i don't know how to close out a question, so please delete this part if in error - thanks!