Solved

Internet Connection Dropping SBS 2003 network

Posted on 2011-03-07
16
436 Views
Last Modified: 2012-05-11
Hi All,

Over the past three days the internet connection is consistantly dropping to the point where it is unusable. (i.e. fr ever 30 secs on it is off for 30 secs).

Now as far as I can see it is must be a problem with the router or internet line. Now BT are saying the connection is running ok and there are no problems?

When it occurs it is also impossible to connect to the url for the router. However server saresremain accessible.

Now the router has DHCP turned off, and the server is resolving the DHCP and the DNS.

Now I thought that this could be a DNS forwarde problem but I am also having trouble remoting into the server from outsidethe network.

Is there anything further I can do to throubleshoot/ensure the server is not the issue?

The router being used is a 2wire supplied by bt.

Kind Regards,

Matt.
0
Comment
Question by:flynny
  • 10
  • 5
16 Comments
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35060871
Oh the joyous BT 2-Wire routers!

If you stop SMTP service on the server when it grinds to a halt - does the problem go away?

Do you have lots of emails in your server Queues?

Is someone sending large emails which makes Exchange work itself silly trying to get the emails out as quickly as possible and as a result, crippling the internet connection?
0
 

Author Comment

by:flynny
ID: 35061184
Hi Alan,

Thanks for your reply.

Now you come to mention it I have noticed that the store.exe has been taking up an awful lot of memory.

At the moment I cannot remote into the server. Once I get on I will post the findings.

Matt.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35061903
Hi Matt,

The Store will chew up memory - but that is quite normal!

If the server goes slow - just check out the queues.

Also - whilst you are not able to get on remotely - have a look at www.mxtoolbox.com/blacklists.aspx and www.blacklistalert.org - check the server's IP Address.  Anything listed?
0
 

Author Comment

by:flynny
ID: 35067207
Hi Alan, again thanks for you help.

Like I said store,exe is taking up alot of memory 282,100k, then its services 104,856k?

I have turned off the Simple Mail Transfer Protocol service and the problems are still there.

The queue is empty (i.e. I have checked the c:\program files\exchsrvr\mailroot\vsi 1)

As far as I am aware nobody is sending out large mail (or they are not admitting to it). Is there any way I can check this or perform anyother checks for you?
0
 

Author Comment

by:flynny
ID: 35067251
Hi Alan,

Also fyi I have run SS 2003 BPA and it has flagged the following issues

Low disk space (this appears twice) the c: has 19% free on it i.e. 2.27 gb out of 12gb
Default instance is not SQL 200 SP4
the installed version of samsrv.dll is not current

also the only other thing we have changed on the server recently is we added a forwarder to a gmail account (i.e. so anything that comes into one of the boxesis also copied to the gmail account)
0
 

Author Comment

by:flynny
ID: 35067613
Alan,
sorry for bombarding with messages! I didnt realise you replid with the blacklist question! and because of the net dropping regularly I am losing what I type!! time to always eep a copy of what i am typing!)

Ok after running the server IP on the frst link all are ok bar;

CYBERLOGIC  TIMEOUT ERROR, Reponse code=2   0
SPAMRBL  TIMEOUT   0

from he second I get the following warning

WARNING: No Reverse-DNS (PTR) is assigned to IP <our ip address>.
Please request your Admin or Provider to fix this.

however this could be because I am in the offie and it timed out.

The problem is now a little more serious because apparently people who are emailing are getting their emails bouncing back? saying the mail address does not exist.

Any ideas?

Thanks again,

Matt.
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 35068130
Can you reinstall SP2 for Exchange please - I have known it iron out many a problem.

The store memory is not unusual - restarting the Information Store Service should free up the memory.

You might have a memory leak!  Is the server fully patched?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:flynny
ID: 35068191
Hi Alan,

Thanks for your reply. Sorry about the repeat on the store.exe, I hadn't seen your previous post in my haste.

I am currently out of the office (and it now will not allow me to remote at all).

As far as I am aware the server is fully patched (would the BPA have pointed this out if not?). If not can you tell me how I can check this for you please?

I will reinstall the SP2 for exchange as soon as I am back in.

I have lso dug out an old draytek router, would it be worth switching to this in your opinion?

0
 

Author Comment

by:flynny
ID: 35071445
Ok I have downloaded and ran the update.exe from the e3sp2eng/setup/i386 folder.

The component selection allowed me to update the following

Microsoft exchange
Messaging and collaboration services
Microsoft exchange system management tools

The others see simply '-' so I assume these were not installed

The were installed to c:\program files\exchsrvr

I then restarted the server

Another thing that is strange is I can remote into the server just fine inside the network but not outside it? I took my laptop which is not connected to the sbs network and connected it wielessly to the router and this is having the same issues

Any way I can check about the patching?

Thanks for all the help. It's most appreciated.

Matt.
0
 

Author Comment

by:flynny
ID: 35080996
Hi Alan,

Just to let you know, I change the 2wire router for an old Draytek I had at home, this seems to have solved all the problems.

Internet has now been stable last night, I can remote into theserver and emails are coming through (thank god!).

Is ths a known problem with the 2wire routers breaking down? as BT were adament it could not possibly be that.

On another unrelated note, installing the SP2 seems to have solved another problem I was facing on this server, where under server management -> performance andmonitoring it was saying the page could not be displayed. This is now back up and running too!

However when I go to the backup section this is still saying the page cannot be displayed?? any ideas with this?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35082690
I've not seen too many 2Wire routers break down - mainly because I never get them out of the box as they cannot block TCP outbound for a range of ports - SMTP Outbound can only be On or Off - which is bloody useless, but being from BT - it doesn't surprise me (laughing).

Glad there was a hidden benefit to installing SP2 - it quite often fixes things that are not working 100% happily and I often re-install it when I face weird issues.

So - sounds like you are good to go. If you need anything else - please let me know.

Best wishes

Alan
0
 

Author Comment

by:flynny
ID: 35096093
Hi alan,

The only other niggling problem the backup section in the server management panel is coming up as page cannot be displayed??

now it is backup just fine so I am unsure of what the problem can be?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35097045
Okay - that's a separate issue to the SBS dropping the network and buried down here is not the place to go into that if you are worried and want it fixed.  A new question for that would be a better place to address that issue.

If all is good with the internet connection issue then it is probably time to close this question down.
0
 

Author Comment

by:flynny
ID: 35118262
Hi Alan

Sorry for the delay getting back to you thanks for ll your help on this. I have already created a topic on this here

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_26766278.html

if you could comment your thoughts here on the subject I would appreciate it.
0
 

Author Closing Comment

by:flynny
ID: 35118265
fantastic, quick and useful responses. a credit to ee!
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now