Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 697
  • Last Modified:

Wordress Pagination Problem

I am a wreck right now... I just put so many hours tweaking this theme.

http://azwm.com

First, let me say this: I have searched the forum for answers,
I have disabled the WP-Navi plug-in,
I have set my permalinks to default,
I have changed category names and more...

Whether I use page-navi plug-in or not, the same thing happens:

As soon as pagination gets to the LAST page for a category, it gets a 404 error.

So, http://azwm.com/category/mortgage-questions/page/2/

works fine. But there are 3 pages.

http://azwm.com/category/mortgage-questions/page/3/ brings me to a dead link / 404 error.

In the category mortgage-news, there are two pages of posts. So, of course, this works: http://azwm.com/news/mortgage-news/

But this is dead:
http://azwm.com/news/mortgage-news/page/2/

I would be SO GRATEFUL for an answer. Thank you in advance.
0
mikegeorge2
Asked:
mikegeorge2
  • 7
  • 3
  • 3
  • +1
1 Solution
 
Sudaraka WijesingheWeb Application ProgrammerCommented:
It's possible that your theme or plugin code might have some thing that affect the  internal page number calculation or the main loop variables. Maybe a custom query?
0
 
mikegeorge2Author Commented:
The only plug-in that I feel could be a problem is called WP Page-Navi. However, when I disabled the plug-in, I still had the same problem.
0
 
Sudaraka WijesingheWeb Application ProgrammerCommented:
Try changing the theme entirely, maybe to the default twentyten and see if the problem goes away. If so, the problem should be theme related and you will need to check the post/loop related template files.
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
jeremyjared74Commented:
I believe it is your permalink structure.

If you go to Settings>Permalinks, try clicking on the default settings and then update. This will let you see if ti is in fact a permalink problem. If it fixes it, but you would still like to use custom permalinks, let me know and I will help you troubleshoot why it isn't working.
0
 
mikegeorge2Author Commented:
Thanks for responding guys / gals.

@jeremyjared74: I changed the permalink structure to "default" and it is still doing it... So frustrated!
0
 
mikegeorge2Author Commented:
@jeremyjared74: Since I changed the permalinks and it did not fix the problem at all, I went back to my old structure.
0
 
jeremyjared74Commented:
Have you tried turning on WordPress debug mode?

You won't want to leave it on, but it may help you troubleshoot the problem.

Here is how:
Add this to your WP-config file:
if ( isset($_GET['debug']) && $_GET['debug'] == 'debug')
  define('WP_DEBUG', true);

Open in new window

Next you can check any page by adding "?debug=debug".
EXAMPLE:
http://azwm.com/category/mortgage-questions/page/2/?debug=debug

Open in new window


Alternatively you can use the WordPress plugin that the WordPress theme repository uses when allowing or rejecting themes:
http://wordpress.org/extend/plugins/theme-check/
0
 
mikegeorge2Author Commented:
I did exactly what you posted and now my whole site is down. I don't know how to fix it or what to do. I copied and pasted the code exactly.

Any ideas? Thanks.
0
 
mikegeorge2Author Commented:
Okay, I got it working again. It had something to do with comments not being commented out of the wp-config file because I used a text editor and it affected word wrap. I opened the CSS in Dreamweaver and hit return a few times and everything is back up.

So I am just going to add:

if ( isset($_GET['debug']) && $_GET['debug'] == 'debug')
  define('WP_DEBUG', true);

anywhere in the code, right?
0
 
mikegeorge2Author Commented:
Okay, I did it... But no bugs are showing up... Not that I can see.

Nothing is showing up actually. Just another 404 error.

http://azwm.com/news/mortgage-questions/page/3/?debug=debug

If I go to page 2, or "the second from the last page", I still do not have a problem, but I still don't see bug information.

http://azwm.com/news/mortgage-questions/page/2/?debug=debug
0
 
jeremyjared74Commented:
I just wanted to make sure...

Do you have enough articles or posts for there to be a third page?
0
 
Sudaraka WijesingheWeb Application ProgrammerCommented:
maybe be the calculation of number of available pages is wrong?
Starting from 1 instead of 0 like things...
0
 
mikegeorge2Author Commented:
Right now, there are 12 posts under the category "mortgage questions." There are 5 posts on page 1 and page 2 and then page 3 is 404 not found.

This is very unusual right? It seems like there would be a simple solution.
0
 
gwkgCommented:
Try changing the 'Blog pages show at most' Settings > Reading and see if it clears it up.

If not, look here: http://wordpress.org/support/topic/default-navigation-is-giving-a-404-error
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 7
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now