Can't authenticate properly on domain when connected to 2 physical wired networks

Hi Experts,

I have a domain workstation that is connected to a Windows Active Directory network (172.x.x.x) and another local network (192.x.x.x).

In order to successfully authenticate on the domain, I'm always forced to disable/disconnect the 192 network connection before I am able to.

I tried the following measures, but met with no success.

1.  Using Network Connection properties, I manually set the metric values of the 172 network to 1 and the 192 network to 2.

2.  I tried setting up a static route for the possible subnets where domain controllers are located to go through the 172 network.

3.  I tried deleting the default route for 192 network.

How can I configure the networks so that they both stay active and I'm able to use the domain services normally?

One example of malfunction is that when trying to add a domain user using the "control userpasswords2" applet, I get an error that a trust relationship with the domain failed.  It seems that any non-cached domain credentials cannot be verified.

Thanks in advance!
Who is Participating?
speshalystConnect With a Mentor Commented:
What is the Binding Order of these 2 Network LInks..

Open "Network Connection" > Advanced>Acvanced Settings
Look under Adapters and Bindings..
Make sure  you is the first in the binding order. .

Hope this helps
Try setting your "Automatic metric" of your network adaptor that is connected to your active directory network to 1 (untick the box next to automatic metric). The automatic metric setting is located under TCP/IP Properties of your network Adapter > Advanced.. button. This will force all requests to go through that adapter first before it will look at the other adapter.
My apologies, ignore my post. I read your question too quickly.
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

waqqas31Author Commented:

You're a genius, it worked!

Thanks a bunch!
waqqas31Author Commented:
Solution couldn't have been more precise!
Glab to be of help !! :)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.