Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 459
  • Last Modified:

unable to access Windows 7 shares in a workgroup from mixed mode enviroment

I have a client with a mixed mode workgroup containing Windows XP, Vista and Windows 7 stations. The 'server' is a Windows 2000 Professional workstation. I was asked to replace the 2000 Professional workstation 'server' with a new Windows 7 Pro 64bit workstation. I created all the users on the local Windows 7 Pro 64bit station and created the shares adding 'Everyone' with Read/Write permissions.

When I try to access the shares on the 'new server' from a WIndows 7 station, I enter the workgroupname\username and password but am only getting a request to enter the credentials again. Some of the Windows XP stations work as expected except for one. Vista does not work and Windows 7 does not.

However, if I enter the username I entered when I setup the Windows 7 Pro 64bit workstation - LBA I get in everytime (same password '2', but I can't enter any other username on the stations I am having the issue with. I have checked the usernames on the stations and the 'servers' and they are correct. Everyone has a password of '2' no quotes.
0
mstumpo
Asked:
mstumpo
1 Solution
 
andossCommented:
Did you set the 'Everyone' group to have Read/write permissions on the folder security aswell as the share?
0
 
virtualxistanceCommented:
try using Computername\username & password while accessing the Win 7 x64 box.

0
 
mstumpoAuthor Commented:
Yes, Everyone has folder level security as well as full share permissions. I have tried computername\username as well as workgroupname\username and none work EXCEPT LBA, which is the account created when the system was first configured.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
CSI-WindowsCommented:
Start group policy editor on the Windows 7 machine (start => gpedit.msc => enter)
Make sure the following policy is not blocking the other user accounts:
"Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment > Deny access to this computer from the network"

If the drive being accessed is the same drive as it was under W2K, then you should try re-applying permissions under Windows 7 in this manner:

Open the right click the root folder of the share, select Properties and then Permissions tab.
Click the Advanced button.
Edit the Everyone group.  Check an permission on and then check it off again.  Click OK and answer Yes if you receive a prompt as to whether the permissions should be applied to all subfolders and files.
0
 
mstumpoAuthor Commented:
The GPO in question is blank. Strange thing is out of 7 stations, 3 connect without requiring any authentication (XP/Win7/XP) and I see the shares. Other stations are a mix of XP/7/Vista and require authentication. I can only get access when entering lba\lba and password of '2' eventhough the account Robert exists on the station and the Windows 7 computer in question with the same password.

everyone has full permissions on the C drive root. Still same issue.
0
 
CSI-WindowsCommented:
Make sure that there are no persistent connections (mapped drives usually) using a different user id than "Robert" - or else you will not be able to present a second set of credentials for the same machine.

I would:
*) Unmap all existing drives to anything on your network.
*) From a command prompt issue "net view" to see if there are any connections to the Windows 7 machine that are not drive letters (UNC, Printers, etc).
*) Create one clean drive mapping and try to let windows use the credentials of the logged in user.

Also, reset the password for Robert on the Windows 7 machine and the machine you are trying to connect from - if by some chance they aren't synced, you might be spinning your wheels for a while trying to figure it out.

Finally, on the machine that is having problems connecting, create a local account for a user id you know works against the Windows 7 machine and login and try to connect from it. This will isolate whether it is truly related to the machine or if there is something misconfigured or corrupt about Robert's profile on the machine that is trying to connect.

0
 
mstumpoAuthor Commented:
I removed all the accounts in question and added them back again. That fixed the issue for some reason. Thanks for all the help.
0
 
ee_autoCommented:
Question PAQ'd and stored in the solution database.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now