Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 857
  • Last Modified:

Sharepoint2010 and SQL server install issues

Hi Experts!

I'm trying to set-up a test Sharepoint 2010 Enterprise server for our small office, but got completely stuck after the Sharepoint installation, and where I'm "configuring" it to work with the SQL server.

My setup (all on one server)
MS Server 2008 Ent R2 SP2 (DC)
Sharepoint 2010 Ent 64bit
MS SQL Server 2008 Ent 64bit SP2

I was able to install the Sharepoint 2010, and SQL 2008 servers, but when I run Sharepoint Configuration Wizard, I can not get through the screen where it asks to specify SQL database name, server name, usernames. It gives me the following error message:

SharePoint Products Configuration Wizard
Cannot connect to database master at QL server at MyServerName. The database might not exist, or the current user does not have permission to connect to it.

That window is asking me for:
a). Database server - which is this same server's name, i'm sure it's correct

b). Database name - Don't know, I probably don't have DB ready for it, but it's also saying that it will create a DB if there's no database with that name... not sure if it applies to Server 2008 though. Please help. How can I create a db in Server 2008, and check if it's working?

"Specify Database Access Account"
c). Don't know this one... I tried to use the same account that I created in AD for my SQL server installation (i used same account for all roles), but it wouldn't work. I also tried using Administrator account, but that didn't work either! Pleas help. How do I create an account that should work?

I'm very new to this, and never before installed MS SQL Server. In a tutorial that I found, it seems that I must set-up a username in the SQL database? But I don't know how do I create a database, and if i use "SQL Server Management Studio", i can't connect to any databases with it.

I've been following this tutorial, but getting completely lost on Step 5 - Administrative and Service accounts. http://andreasglaser.net/post/2009/11/18/Installing-SharePoint-Server-2010-on-Windows-Server-2008-R2-and-SQL-Server-2008-R2-Part-5-Administrative-and-service-accounts.aspx

Any help is greatly appreciated! Thanks in advance! :-)
0
Kaptain1
Asked:
Kaptain1
  • 9
  • 8
  • 3
  • +1
2 Solutions
 
Minesh ShahSharePoint & all about itCommented:

The login from which you logged in:
Give it permissions at Sql:

Open sql mgt studio > databases > security > logins > right click: new login: add the login as mentioned in 1st line & give full permissions).

This will suffice.


Pretty simple,
i actully didn't understood in multiple id installation, if we do not give this access the same error will come and has to come since it doesn't have access.
wondering if anyone can put some in the purpose: why installation is required through different logins and not giving cross permissions.
0
 
Minesh ShahSharePoint & all about itCommented:
simplified: log in account of wfe (spfadmin) needs some permissions on sql.
so giving solves error.
0
 
Justin SmithSr. System EngineerCommented:
Mine is correct, you need to grant your install account (accout you are logged in as) proper access on the SQL Server.  It needs at least "dbcreator" and "securityadmin".  This is the only security you have to specifiy in SQL, everything else will be automatic.

When it asks for a DB name, it's asking you what you want your config database to be named.  It will then create it.

The database access account is your farm admin account.  You are telling the wizard what account to set your Central Admin app pool to, and what account you want the Timer service to run as.  This should be an AD account, just a regular domain user, it doesn't need any special permissions.

After the wizard completes, look in SQL and you will have two new db's, one is the config and the other is the Central Admin content db.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
KoenVostersCommented:
You need to open the SQL port on the firewall of your servers (or on the firewall in between the servers if there is one), 1433. Just turn off the firewall and test if it works then, if it does, open port 1433 for tcp and udp (or another one if you are not using the default port)
0
 
Kaptain1Author Commented:
Thank you for all of the helpful info!

I understand that I need to "grant permission" to the user that I created in AD for SharePoint.

However, I can't figure out how to log-in to the database where I need to set the permissions for the account. If I open the MS Server Management Studio, it doesn't display any databases... I'm assuming that i have to first "connect" to the database using "New Query"? I spent quite some time trying to connect to the db using different logins and settings, but no luck.

Should there be a database there already created? The only one I was able to connect was with "SQL Server Compact Edition" - but I'm assuming it's not the correct one? And even there, I wasn't able to find the "security" entry/button...

Thanks for helping :-)
0
 
Kaptain1Author Commented:
I tried logging-in to the SQL server a few more times, but it gives me an error message:

TITLE: Connect to Server
------------------------------

Cannot connect to 127.1.1.1.

------------------------------
ADDITIONAL INFORMATION:

Login failed for user 'Domain\username'. (Microsoft SQL Server, Error: 18456)


I'm assuming that the server is there... but for some reason it won't take either one of 2 usernames that I have on this server!?

Any help is appreciated.

Thanks!
0
 
Justin SmithSr. System EngineerCommented:
It's not showing any db's becuase nothing has been created yet, because your install account doesn't have rights to create db's.

You need to look in the Security section of SQL Manager, and create a new account for your install account.  On the new account screen is a section to grant roles.  You need to give it at least dbcreeator and securityadmin.
0
 
Kaptain1Author Commented:
Could you please provide a few steps how to get to security settings for sql? I've spent probably half a day stuck on this, but can't figure it out..
0
 
Justin SmithSr. System EngineerCommented:
A quick google search could help you.

CHeck the first section here: http://msdn.microsoft.com/en-us/library/aa337562.aspx
0
 
Kaptain1Author Commented:
After I open the Object Explorer, it shows me the "login/connection to server box", where I must choose either "Database Engine" or a "SQL Server Compact", there's also an "authentication method" and username/password. I've tried all different kinds of possibilities on this login box, but can't login to any SQL server, and can't see "sql security settings" anywhere. More guidance please.

Tried researching on Google, but everyone shows those screenshots of the "SQL Server Management Studio" , and have a database file open in there, with a bunch of folders on the left and options. - I don't have that anywhere, and can't location "SQL Security" anywhere. :-/
0
 
Justin SmithSr. System EngineerCommented:
So you can't even log into the manager?  Sounds like security was never properly configured in SQL from the get go.

Can you log in as your sql service account?
0
 
Justin SmithSr. System EngineerCommented:
The auththentication method PROBABLY needs to be windows auth (which will try to log in as your logged in AD account).  You need to be logging into the database engine.  The naem of the db engine will be servername\instance.  In most cases, it's just the server name since by default you will use the default instance.
0
 
Kaptain1Author Commented:
Is it the account that sql asked me to create during installation? I created it in ad, regular user, and used it every time sql install asked me to specify an account to use. It won't let me login with i.
0
 
Justin SmithSr. System EngineerCommented:
its the account the sql service is running as.
0
 
Minesh ShahSharePoint & all about itCommented:
dear author,
this is pre-assumed that sql is properly installed on your sql server and you are loging into it through RIGHT sql instance since the q was only for permissions lag on sql.
0
 
Kaptain1Author Commented:
I'm going crazy... I have re-installed the SQL 2008 R2 server, took note of all of the accounts set-up, followed the tutorial here: http://andreasglaser.net/post/2009/11/18/Installing-SharePoint-Server-2010-on-Windows-Server-2008-R2-and-SQL-Server-2008-R2-Part-5-Administrative-and-service-accounts.aspx 

And still the same thing... can't log-in. :-(
0
 
Kaptain1Author Commented:
Ok. I got through my roadblock of not being able to connect to the SQL server via the MS Server Management Studio.

I had to log-in to the MS Server Management Studio with the Windows Account that I had set-up during the MS SQL Server 2008 R2 installation, meaning that I had to Log Off my windows Administrator account, log-in to windows MySQLserverManagementAcct, then i was easily able to log-in with the MS Server Management Studio... added my windows Administrator account to the SQL Logins, logged back in to my windows Administrator account, set-up permissions for the sql administrator acct in the SQL Server management studio, and sharepoint finally accepted my login info and allowed me to continue the sharepoint setup wizard!

Hope this will help someone, and save them 3 days of frustration.
0
 
Justin SmithSr. System EngineerCommented:
Didn't I tell you to log on as that account in comment 35084336?
0
 
Kaptain1Author Commented:
You didn't tell me to log-in into that account in Windows, i was trying to log-in to it thorugh SQL server management thing...  I'll be glad to award you point for helping though!
0
 
Kaptain1Author Commented:
The directions were very vague, and I had to spend another day trying to figure it out, and trying all other wrong paths.
0
 
Justin SmithSr. System EngineerCommented:
This isn't a training site.  We point you in the right direction.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 9
  • 8
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now