Solved

Exchange 2007 - Transport Service Not Starting

Posted on 2011-03-08
10
1,134 Views
Last Modified: 2012-05-11
I have a user that sent another internal user a huge attachment.  Now my transport service won't start and just hangs on "starting".  Because the service wont' start, I can't view the queue.

How can I get this message cancelled and the transport service running again?

James
0
Comment
Question by:james3760
  • 5
  • 2
  • 2
10 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35067082
A huge message shouldn't cause the transport service to stop.  It's likely this is being caused by something else.

I've seen this happen with 3rd party virus and SPAM software so if you have any in the server uninstall it then reboot to see if the problem resolves.
0
 

Author Comment

by:james3760
ID: 35067214
No, I don't think that's it.  I'm not running virus scan on this server, and the spam software is the exchange built in.  Been running for a few years now.   The transport service went down within 20 minutes of someone sending a 1GB video file via email.  

I've restarted several times, not sure what to try at this point.
0
 
LVL 5

Expert Comment

by:zippybungle2003
ID: 35067645
How much drive space is free on the logs drive....you may be experiancing back pressure..


http://www.petenetlive.com/KB/Article/0000165.htm
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:james3760
ID: 35067936
No, that's not it either.  I have 253Gig free on that drive.  However, a few moment ago I was thinking I might have corrupt log files, so I cleared out my logs and voila, the transport service now runs.  However, no mail is flowing.  I've also noticed that the service occasionally stops, but it'll start as soon as I click on it to.

some progress I guess, but no mail flowing.
0
 
LVL 5

Expert Comment

by:zippybungle2003
ID: 35068050
If you have deleted your logs your now in a world of pain!

You need to now run a eseutil to recreate your logs, or restore from backup...Anyone here got a guide on this for James?
0
 

Author Comment

by:james3760
ID: 35068229
No, not deleted.  I cleared them as a test.  Then put them back.  It allows me to run the service now, but it seems to run, then stop.  No more boot errors, it looks okay, but no mail flowing.

I haven't modified the send connectors and I hadn't made any changes at all until I started troubleshooting.  

So I can start the service now, but strangely enough when I try to run the queue tools, it gives an error that the service isnt' running.  when I check it, it seems to stop on it's own.  But at least now, it lets me restart it, though, still no luck.

0
 

Accepted Solution

by:
james3760 earned 0 total points
ID: 35068490
Looks like I got it working.  I went to c:\program files\microsoft\exchange server\transportroles\data and renamed it to data_old, then restarted the services and it recreated the data folder and then rebuilt the log files and the mail started flowing.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35361009
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0
 

Author Comment

by:james3760
ID: 35487463
Yeah, it's closed.  I didn't get the answer I needed here, but I did get it fixed and posted the results in this thread.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question