How to diagnose https connection not working

Hi,
I successfully setup a test system using a ssl certificate / https website for the first time and now rolling out to a 'production' machine. I've installed a new certificate and setup pc (xp pro / iis5.1 - don't judge!) in the same way as my test machine as far as I can tell but when I try to access a page using https I get browser error 118 (operation timed out).
Can someone please help me diagnose the problem - here's my 2c worth so far..:
1. Site works fine on http (which I need to leave in place)
2. Checked port 443 is open on main router (shared offices so IT dept have confirmed this)
3. Disabled pc security software firewall (ESET)
Current website settings as shown in attached image.
Thanks.

server-website-settings.jpg
nigelr99Asked:
Who is Participating?
 
Brad HoweConnect With a Mentor DevOps ManagerCommented:
If it is all good, install SSL diag and give it a test. After is searches, scroll to your site and verify certificate chain and root is installed.
Run, SSL Diagnostics to troubleshoot.

1. Firewall. you could test this by using telnet to port 443.  If it is open, it will connect and go black.
    eg: telnet your.domain.com 443

2. Does it browse locally?

3. SSL Diagnostics
x86
http://www.microsoft.com/downloads/en/details.aspx?familyid=cabea1d0-5a10-41bc-83d4-06c814265282&displaylang=en

x64
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=1CBFB70E-F442-4BB2-940B-351C3A7D62CF&%3Bdisplaylang=en


Let us know,
Hades666
0
 
nigelr99Author Commented:
Thanks,

In response:
1. I disabled local firewall but telnet could still not connect. I had IT dept to re-check 443 port forwarding which they did.
2. I cannot connect locally using https://locahost
3. Ran ssldiag and had handshake error as shown in attached image.
Looked for some more information on the error number but struggling to find a way forward. Any ideas appreciated.

server-ssl-error.jpg
0
 
Brad HoweDevOps ManagerCommented:
If you cannot connect even locally then it is not a firewall issue.

If you open up IIS Manager and review the directory Security for the certificate, is the entire chain present?

-Hades666
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Brad HoweDevOps ManagerCommented:
you may also what to verify the permissions on the machinekey folder.

Default permissions for the MachineKeys folders
http://support.microsoft.com/?id=278381 

Or

as simple a reboot...

Hades666
0
 
nigelr99Author Commented:
Ok, Certificate chain looks fine (see image) - I even tried removing / re-importing certificate.
Permissions on MachineKeys folder look OK.
Rebooted and still no joy. I'm sure I'm missing something simple here. IT dept is swapping router overnight but if I can't connect locally then there's not much point in that!
Any more ideas please?
Cheers.

server-cert-path.jpg
0
 
nigelr99Author Commented:
It turns out the 'IT dept' router uses https for remote management which has now been disabled and after re-installing certificate (out of desperation if nothing else) and then stopping and re-starting w3svc service it magically works!
Thanks for you help with diagnostics hades666 - I will award you the points. Cheers!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.