• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1484
  • Last Modified:

MySQL wont start on snow leopard

Hi All

I have another issue on my Xserve running snow leopard 10.6.5.
I cannot seem to get mysql to start, the system log repeatedly gives me the following
"Mar  8 23:06:59 "server" com.apple.launchd[1] (org.mysql.mysqld[14545]): Exited with exit code: 1
Mar  8 23:06:59 "server" com.apple.launchd[1] (org.mysql.mysqld): Throttling respawn: Will start in 10 seconds
Mar  8 23:07:09 "server" com.apple.launchd[1] (org.mysql.mysqld[14547]): Exited with exit code: 1
Mar  8 23:07:09 c"server" com.apple.launchd[1] (org.mysql.mysqld): Throttling respawn: Will start in 10 seconds"

MySQL Log gives the following
"2011-03-08 22:16:29 Australia/Sydney   Starting MySQL Service
2011-03-08 22:16:29 Australia/Sydney   Starting MySQL daemon...
2011-03-08 22:16:29 Australia/Sydney   MySQL: verifying/installing default my.cnf
2011-03-08 22:16:29 Australia/Sydney   MySQL startup options: socket=/var/mysql/mysql.sock; datadir=/var/mysql; pid-file=/var/mysql/cDNS.NAME.pid; network=YES
2011-03-08 22:16:59 Australia/Sydney [E]  {
    NSLocalizedDescription = "MySQL daemon start up timed-out.";

Starting it via server admin just sits on "Starting", trying to start it via terminal gives me
mysql = _empty_dictionary

Tried to install the latest version of mySQL however still getting the same issues.
Any help would be appreciated
0
ProphecY01
Asked:
ProphecY01
1 Solution
 
Rahul AgarwalTeam LeaderCommented:
You can try the Folllowing steps:

Open Terminal & Type:
sudo chown -R root:wheel /Library/StartupItems/MySQLCOM

Restart the computer

Open Terminal & Type:

cd /usr/local/mysql to navigate to the mysql interface.

Type: sudo echo

You will be asked for your computer admin password

Then type:

sudo bin/mysqld_safe &

Then type:

bin/mysqladmin -u root password 'xxxxxxxx' to enter a root password for the MySQL database (replace xxxxxx with your chosen password. This should probably be different from your computer password. Don't forget the single quotes). Logout of Terminal

Then look at System Preferences. Under "Other", click the MySQL button. It should say "The MySQL Server Instance is running". If you want MySQL to start on StartUp, check the box "Automatically Start MySQL Server on Startup"

For reference:
http://discussions.info.apple.com/message.jspa?messageID=12820394#12820394
0
 
TolomirAdministratorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now