• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2583
  • Last Modified:

small business server 2003 event error 7011 server running very slow


The sbs server has been running very slow and seems to freeze up 3 or 4 times a day. The system is using very  little system rescource (CPU and Memory) even when the system becomes unresponsive. Everything seems to carry on working fine after the system freeze.

the only relevant errors I can see in the event log are.

Type error
event 7011

Timeout (30000 milliseconds) waiting for a transaction response from the NtFrs service.

and at the same time I will occasionally get a DNS error which I believe is caused by the above error.

event error 4014 and 4004

The DNS server timed out attempting an Active Directory service operation on ---.  Check Active Directory to see that it is functioning properly. The event data contains the error.

The DNS server was unable to complete directory service enumeration of zone inspired.local.  This DNS server is configured to use information obtained from Active Directory for this zone and is unable to load the zone without it.  Check that the Active Directory is functioning properly and repeat enumeration of the zone. The extended error debug information (which may be empty) is "". The event data contains the error.

I am not getting any file replication error but about 4 month ago I ran a fix on error id 13568

Expand HKEY_LOCAL_MACHINE.
Click down the key path:
   "System\CurrentControlSet\Services\NtFrs\Parameters"
Double click on the value name
   "Enable Journal Wrap Automatic Restore"
and update the value.

This fixed that error, I only mentioned this as they seem to be related.

any ideas would be much appreciated.
0
corecc
Asked:
corecc
  • 4
  • 4
1 Solution
 
Sai (Simon) HaynesCommented:
Hi,
    Before offering a solution of any sort can you answer the following;

-When did the server begin exhibiting this behaviour?
-Have any software of hardware changes taken place?
-Do the event logs show any other errors or cause for concern?
-When the server freezes are the clients connected (if any) seeing any abnormal behaviour?
-What applications\antivirus are you running on the box?
-Is your Server up to date?

Really the above is just questioning the general health of the server itself

Looking at some of the sbs newsgroups it seems the following has resolved the lockup issue for others

(backup key first of course)

1.  Please try to change the autodisconnect value for the LAN setting under
the registry key

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

Set the Autodisconnect value to 0xfffff. See the following KB article
138365 for an article describing the Autodisconnect parameter. The value
0xfffff is  the highest value allowed on a domain controller. The default
value on my SBS 2003 server was 0xf.

Let us know how you get on

Thanks


0
 
coreccAuthor Commented:
Hi Saihaynes,

The server has been running slow for a while it is difficult to give a date as the event error: 13568 also slowed it down and once that was resolved it was running ok but on logging on recently I noticed the slow down and checking the event log the 7011 error has been happening for a long time.
another thing to not is rebooting tales about 30 mins and in my experience 10 min is what I would expect.

No software or hardware changed in the past year.

The events mentioned are the only error events on the server.

The clients are not affected.

I have changed the above value and will reboot tonight and let you know if this has helped.

Many thanks

AVG network addition 9.0 is install and Acronis sbs  
0
 
Sai (Simon) HaynesCommented:
Good Morning,
                          How did you get on with the regedit?

At which point does the server hang on reboot, is it the shutting down or starting up or both?

I would suggest disabling any third party applications one by one and seeing if that improves the situation


Thanks

Sai
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
coreccAuthor Commented:
Hi,

Yes shame I am still getting the 7011 error. it is slow on bootup rather than shut down. I will try disabling everything tonight and seeing if it makes a differance.

Thanks

Baz
0
 
Sai (Simon) HaynesCommented:
Hi,
    Sorry to hear you are still receiving the error, I found the following on a SBS newsgroup

If you are still receiving the 7011 error please try the steps below;
). Start Registry Editor (Regedit.exe).

2). To change the value data for the ServicesPipeTimeout DWORD value to
60000 or more in the Control key, follow these steps:

a.      Locate and then click the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet

b.      Click the "Control" subkey

c.      Right-click the "ServicesPipeTimeout" DWORD value, and then click

d.      Click "Decimal".

e.      Type "60000" (without the quotation marks) or more, and then click "OK".

3). If the "ServicesPipeTimeout" value is <not> available, add the new
DWORD value, and then set its value data to 60000 in the Control key. To do
so, follow these steps:

a.      Locate and then click the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet

b.      Click the "Control" subkey.

c.      On the "Edit" menu, point to "New", and then click "DWORD Value".

d.      Type  "ServicesPipeTimeout" (without the quotation marks), and then
press ENTER.

e.      Right-click the "ServicesPipeTimeout" DWORD value, and then click

f.      Click "Decimal".

g.      Type a value of "60000" (without the quotation marks) or more, and then
click "OK".

HINT: The value is 60000 milliseconds and is equivalent to 60 seconds or to
one minute. Note This change does not take effect until the computer is
restarted.

In reference to the slow speed/freeze take the following steps to disable third party services;

1. Click Start->Run...->type msconfig and press Enter.
2. Click Services tab and select Hide All Microsoft Services and Disable
All third party Services.
3. Click Startup tab and Disable All startup items.
4. Click OK and choose Restart.
5. After reboot, check whether the problem still occurs.
6. If there are no more problems, please use the above steps to enable
services and startup items one by one in order to figure out the root cause
of this issue.

Let me know how you get on

Sai
0
 
coreccAuthor Commented:
Hi,

New update, I have noticed that the hard drive queues run at 100% all the time which would be the reason it is running so slow, rather than the 7011 error. I have checked the processes that are running IOwrite and IOreads and there is nothing strange regarding usage, so when I remove all the none  MS applications as suggested we will see if any of these are causing the problem.

Thanks
 
Baz
0
 
coreccAuthor Commented:
The solution fixed my 7011 error many thanks, it turned out the the server running was due to cacheing being switched off on the hard drive which I don't know why that was but thanks for helping me problem solve.
0
 
Sai (Simon) HaynesCommented:
No worries, glad its all sorted

Sai
0
 
ItsBrentCommented:
What is marked as the solution was not what the author said the solution was.  The author said he turned caching on to fix the problem.
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now