Windows Photo Viewer on Server 2008 Access Restricted

When using our terminal server - Server 2008 R2 x64 - users are unable to view files with Windows Photo Viewer.

Files can be accessed from anywhere (on the terminal server or the file server), either by double-clicking, right-click and Previewing or right-click and Open With. The error is as follows:

[Network Error]
Windows cannot access <FILENAME>
You do not have permission to access <FILENAME>. Contact your network administrator to request access.

I am fairly confident that the problem is not a permissions issue with the files themselves, as they can be opened in any other application (e.g. paint) with no problems. I have replaced the permissions anyway, but this has not had any effect.

I am also fairly confident that the problem is not GP related, as it occurs for all users (domain admins included) and for a test user that I have created and to which no GPs are applied.

Users also have read and execute permissions on shimgvw.dll.

Cheers,

Sam
ititecsuppAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

synetronCommented:
you mention terminal services so this limitation comes to mind.

it can only be opened one time for one user.

http://support.microsoft.com/kb/980393/en-us

to test, i'd log out of all local accounts, ensure no terminal services clients are connected and only connect 1 account.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ititecsuppAuthor Commented:
I have applied the hotfix, though contrary to the documentation, it does require a restart. The server is live and constantly in use during office hours, so restarting to apply the fix or logging out all users are not viable options for the time being - I would need to request server downtime for the weekend.

I don't believe that this is the issue though, as the hotfix is dated 03/2010. The server has been live for almost a year - this is only a recent development (about 2 days ago). Windows Photo Viewer has always worked in the TS environment, so unless a recent update has knocked it out, I don't think that this is the issue.
0
markOandPCommented:
Hello,

i work with a software company, our software opens images using the default file association.
I'm having the exact same issue with Windows server 2008 R2 servers, this hotfix resolved the issue completely.

However, this hotfix cannot be applied to Windows Server 2008 Standard? i get the message "the update does not apply to your system" when running.

does anyone know of a similar hotfix or workaround?

0
danduxCommented:
I am having the same problem on only one of our two terminal servers, but these posts are from March of 2011. I have been regularly installing 2008r2 updates. Wouldn't hotfix 309312 have been included in one of Microsofts update packages by now? If so does anyone no which package and how I can verify whether or not it has already been applied.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.