Solved

Restore a backup config to a wiped Cisco 831 router

Posted on 2011-03-08
12
741 Views
Last Modified: 2012-05-11
I have a backup config of a Cisco 831 router that I’m trying to restore on a different 831 router. I followed Cisco’s directions on resetting the router to factory defaults, which worked fine.

I went through the “new setup wizard”, after the router reset, and configured an IP of 192.168.16.1 to FastEthernet01 on the router. I then statically assigned my laptop 192.168.16.100, plugged it into FastEthernet01 and can’t ping 192.168.16.1 nor telnet to it. (I am doing all this via the console which is plugged into my production laptop).

I need to be able to tftp the backup config from the 192.168.16.100 laptop to the newly wiped router. What am I doing wrong?

Thank you!!
0
Comment
Question by:Dopher
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
12 Comments
 
LVL 1

Expert Comment

by:amulheirn
ID: 35070721
Hi -
Well...  I am not sure why the ping isn't working.  It could be that the interface on the Cisco is in shutdown, but I would have thought that the setup wizard would un-shutdown the interface for you...

What is the subnet mask you are using on the fa0/1 interface and on your laptop?  If your mask is too small, that might put your laptop and the device in different networks - making them unreachable.

If you console onto the router, are you able to ping the laptop at all? (You might need to check you've got any firewall on the laptop disabled).


Personally, the way I find easiest to restore a configuration to a cisco router is simply to open it in Notepad, copy it to the clipboard and paste it into the console session you've got (obviously in configure mode).  

Let me know how you get on.

Cheers,

A.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 35071415
I think you need to reset acl 23 or permit any:

conf t
 access-list 23 permit any
0
 

Author Comment

by:Dopher
ID: 35083319
Thank you for your suggestions, thus far!

I reset the router back to factory defaults (again), and ran the basic setup. I configured FastEthernet 1 with 192.168.16.1/255.255.255.0 and entered the "access-list 23 permit any" config, per ikalmar. I then connected a cat5 from the laptop (192.168.16.50/255.255.255.0) and am unable to ping the laptop from the router (via console) or the router from the laptop, etc... I'm sure I'm doing something wrong... Here's the running-config, any other thoughts?

Router#sho running
Building configuration...

Current configuration : 1081 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vV0K$Q8zyVaAf5yFltkfPT5/tL1
enable password cisco123
!
no aaa new-model
no ip routing
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface Ethernet0
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
!
interface Ethernet2
 no ip address
 no ip route-cache
 shutdown
!
interface FastEthernet1
 duplex half
 speed auto
!
interface FastEthernet2
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet3
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet4
 shutdown
 duplex auto
 speed auto
 ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!access-list 23 permit any
!!
control-plane
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password cisco123
 login
!scheduler max-task-time 5000
end
 
Router#
0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 35083384
you need to enable the interfaces:

int fasteth 0
 no shut
int fasteth 1
 no shut
int fasteth 2
 no shut
int fasteth 3
 no shut
int fast eth 4
 no shut
int vlan 1
 des LAN
 ip add 192.168.16.1 255.255.255.0
0
 

Author Comment

by:Dopher
ID: 35084974
I did most of what ikalmar said, with the exeption of "int vlan 1", "des LAN", as the router didn't accept those commands. here's the updated config:

Router#sho run
Building configuration...

Current configuration : 1051 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vV0K$Q8zyVaAf5yFltkfPT5/tL1
enable password cisco123
!
no aaa new-model
no ip routing
!
!
!
!
 --More--         no ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface Ethernet0
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
!
 --More--         interface Ethernet2
 no ip address
 no ip route-cache
 shutdown
!
interface FastEthernet1
 duplex half
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
ip forward-protocol nd
!
 --More--         no ip http server
no ip http secure-server
!
!
access-list 23 permit any
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password cisco123
 login
!
scheduler max-task-time 5000
end
0
 
LVL 1

Expert Comment

by:amulheirn
ID: 35087617
I'm not sure what ikalmar is talking about, because the command he's given you creates an access list that is not applied to any interface - as a result it won't be used.  It just sits in the config doing not a lot.

You can't configure 'int vlan' because a VLAN is something you configure on an ethernet switch - and a Cisco 800-series is a router.

For some reason, the setup wizard doesn't appear to have worked - which is wierd.

Try this:

conf t
  int fa1
  ip address 192.168.16.1 255.255.255.0
  no shutdown
end

copy running-config startup-config


Now plug your PC's ethernet into fastethernet 1 and give it another go.



0
 
LVL 1

Expert Comment

by:amulheirn
ID: 35087661
Oh - one more thing that might trip you up later - I notice that there is the command "no ip routing" in the configuration for some reason (a few lines down from the "hostname Router" command).

That turns off routing on the device which might be an issue if you want it to do some routing   ;)

To enable that:

conf t
  ip routing
  end


And to save the config:

copy running-config startup-config


0
 

Author Comment

by:Dopher
ID: 35097447
Thank you amulheirn, what you say makes sense! Now, when I do:
config t
  int fa1
  ip address 192.168.16.1 255.255.255.0

I get:
"% IP addresses may not be configured on L2 links."

Ideas? (Many thanks!)


0
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 250 total points
ID: 35097520
you need to create VLAN interface

int vlan 1
 des LAN
 ip add 192.168.16.1 255.255.255.0

0
 

Author Comment

by:Dopher
ID: 35097611
ikalmar - I triend that commant, to create a VLAN, and get
"Router(config)#int vlan 1
                                ^
% Invalid input detected at '^' marker.
0
 
LVL 1

Expert Comment

by:amulheirn
ID: 35097713
Oh - I see...  Gotta apologise to ikalmar - I think he is right.

So the router you've got has four LAN ports, which is an ethernet switch inside the router.  The ports are layer-2 ports only - if you want to put an IP address on them, you *should* be able to do as ikalmar says - enter the command 'int vlan 1' and put your 192.168.16.1 address there instead.

However, I think the reason it may not be letting you do that is that your configuration above has 'no ip routing' in it for some reason.  

Can you try:

conf t
  ip routing
  int vlan 1
  ip address 192.168.16.1 255.255.255.0
  end

write memory

If that doesn't work, does it allow you to put the IP address on ethernet 0 (rather than the fast ethernet ports you've been using so far)?

I am assuming that your router looks like the on in the picture at the following link - i.e. four fast ethernet ports, one WAN port (not fast ethernet):

http://www.cisco.com/en/US/docs/routers/access/800/831/hardware/quick/guide/831qsg.html#wp1042876

Cheers,

A.
0
 

Author Closing Comment

by:Dopher
ID: 35182568
Thank you all!
0

Featured Post

Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month7 days, 17 hours left to enroll

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question