Solved

How to move file/folder permissions with RichCopy?

Posted on 2011-03-08
11
1,315 Views
Last Modified: 2012-05-11
Hello

I'm trying to copy data from one server to another. I downloaded RichCopy on my desktop and I'm running a test before I do my live data. I set my source destination to a mapped drive i have and my destination folder to another mapped drive I have on my new server. When I started the copy I left the default settings on RichCopy and noticed it just copied all data within a folder and not the whole folder. How do copy the whole dir with file/folder permissions to my new server.

Server 2003 DC (Going to be backup DC) - 192.168.1.2
Data - (D:) Directory
Renal Common - Folder
Accounting - Folder
IT Management Console - Folder
Clinics - Folder

Server 2008 New DC (Primary) - 192.168.1.173
Data - (D:) Directory
Need to move data here

Thanks,

nimdatx
0
Comment
Question by:nimdatx
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 35071393
It sounds like you need to map the drive to the level above the one you want to copy.  Either that, or go ahead and create the folder on the destination and copy into it.

That said, why not use robocopy?

robocopy source destination /e /sec
0
 
LVL 1

Author Comment

by:nimdatx
ID: 35071695
I downloaded RoboCopy GUI and selected the source, which is the IT Management folder. When I map I can not map to the root of IT Management Console folder, which is DATA directory, so it just gives me the option to move data within IT management console. I created the Folder IT Management Console on my new server and set the target to this new folder. When I try to select Start Copy F5, it's greyed out. I'm not sure if I'm doing something wrong.

 RoboCopy
0
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 35072163
This is the equivalent command line for what you're doing in the GUI.  Give it a shot:

robocopy t:\ "s:\it management console" /e /copyall /r:10 w:30
0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 
LVL 1

Author Comment

by:nimdatx
ID: 35072271
ERROR : You do not have the Manage Auditing user right.
*****  You need this to copy auditing information (/COPY:U or /COPYALL).

       Simple Usage :: ROBOCOPY source destination /MIR

             source :: Source Directory (drive:\path or \\server\share\path).
        destination :: Destination Dir  (drive:\path or \\server\share\path).
               /MIR :: Mirror a complete directory tree.

    For more usage information run ROBOCOPY /?


****  /MIR can DELETE files as well as copy them !
0
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 35072339
Okay, try:

robocopy t:\ "s:\it management console" /e /copy:ADOST /r:10 w:30
0
 
LVL 1

Author Comment

by:nimdatx
ID: 35073028
What if I want to do the whole D: Directory on old Fileserver to new server? If I don't then I'll need to do each folder individually.
0
 
LVL 34

Accepted Solution

by:
Paul MacDonald earned 500 total points
ID: 35073349
Map a local drive letter to the D: directory on the old file server, then copy that drive letter (as the source) to the new location (as the destination).  Robocopy doesn't care how much data you're moving.
0
 
LVL 1

Author Comment

by:nimdatx
ID: 35073378
Ok makes sense. With the GUI (cause I do not know the cmds) how do I ensure the copy button isn't greyed out and file/folders permissions move over?

Thanks so much.

nimdatx
0
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 35073497
I've never used the GUI, so I can't say for sure.  You got an error saying you didn't have permissions to coyp auditing information, so you could try clearing that /COPY option.  Also, in the example image you posted, I guess I would start by wrapping the Target Directory in quotes.  
0
 
LVL 1

Author Comment

by:nimdatx
ID: 35073725
paulmacd,

in order to copy I had to choose the option tab and browse to Robocopy.exe.



Thanks so much for all your help.

nimdatx Robocopy GUI
0
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 35073735
Ah, well I learned something today!
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
OfficeMate Freezes on login or does not load after login credentials are input.
The view will learn how to download and install SIMTOOLS and FORMLIST into Excel, how to use SIMTOOLS to generate a Monte Carlo simulation of 30 sales calls, and how to calculate the conditional probability based on the results of the Monte Carlo …
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question