Solved

SBS 2008 SQL 2005 & MICROSOFT##SSEE Not Releasing Memory

Posted on 2011-03-08
8
1,954 Views
Last Modified: 2012-05-11
I am using Backup Exec 2010 R2 on this SBS 2008 server, and it backs up 20Gbs of data.  It take about an hour and half or even two hours to do so.  I believe the slow down is backing up the System State.  I also need to mention, this is clean install of the OS and Backup Exec 2010 only.  I have all OS services pack and patches applied, and Backup Exec is all up-to-date too.  I noticed the problem is the Windows Internal Database (MICOSOFT##SSEE) sqlservr.exe consumes 4Gbs+ of memory, and does not release the memory unless the Windows Internal Database service is restarted, or the server is rebooted, or if the sqlservr.exe (SQL Server Windows NT -64-bit) process is terminated.  

I decided to implement the max amount of memory to 2147Mbs for both the MSSQL$MICROSOFT##SSEE and SBSMonitoring SQL instances as per the following article:

http://msmvps.com/blogs/bradley/archive/2010/11/08/throttling-the-memory-in-sbs-2008.aspx

I have noticed the sqlservr.exe process now remains active witth a max memory allocation of 2.295,396K.  I am not sure if this actually the best thing to do.   Maybe what should be done is simply leave the default memory settings alone, and simply restart both the SBSMONITORING and MSSQL$MICROSOFT##SSEE services every morning at 5AM.  A simply batch file with the following commands should do, but my concern is I do this will it possibly cause some sort of corruption or problems down the line.  

net stop mssql$sbsmonitoring
net start mssql$sbsmonitoring
net stop mssql$microsoft##ssee
net start mssql$microsoft##ssee

This server installation was done using the defaults.  I am not sure if I should leave the max memory settings as is, or restore the default setting back, or simply restart the services as described above, or even simply leave everything as is.  I just want to new server to run smoothly, and have all the programs get along and place nice with each other.  
0
Comment
Question by:cmp119
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 50

Expert Comment

by:Lowfatspread
ID: 35071559
it is expected and desired behaviour ...

you want the dbms to utilise all the memory you allocate to it ... and it will do so...
even to the extent of doing extra work in the initial phases aftyer start up to ensure that its buffer pools are
full...

it is up to you DBA/ Server Administrator to consider what the optimal balance is for your system , partiiculaly if you have
multiple instances of a database server running or are sharing the server between the databases and other applications
as to what degree of ram and/or processors you allocate to each service...


0
 
LVL 5

Expert Comment

by:VENKAT KOKULLA
ID: 35872969
It's good to leave the sql as per default settings unless you need them to configure to use a range.
SQL behaves in it's own way like it will take memory what ever it requires and releases the memory if it doesn't require. Please check the dependency of apps running on the sql and check the memory utilization at a peak state.
As you mentioned Sql is not releasing memory... It will be not like the way sql plays, might be some sessions are running on the background in sleeping mode...have you checked..!
so keep sql as per default settings and lets keep an eye on the processes running on the background so that we can figure out which processess are making the sql to utilize more memory, according to that we can necessary action to get this issue resolve......

--Venkat
0
 

Author Comment

by:cmp119
ID: 36007711
I've requested that this question be deleted for the following reason:

I found my own solution.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 36000526
>>I found my own solution.<<
Please share it with the EE Community so that we can all learn.
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 36007712
The author was provided good feedback, unfortunately they chose not to followup or provide their own solution.
0
 

Accepted Solution

by:
cmp119 earned 0 total points
ID: 36009923
This is a known issue specifically with Windows 2008 Server and Backup Exec 2010 and all previous versions.  This issue was corrected with Backup Exec 2010 R3.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
DHCP Server Service stops on SBS 2011 3 78
aws pricing 2 69
kill process lock Sql server 9 75
Microsoft Small Business Server 2011 Indexing Issues 4 31
This guide is intended to provide step by step instructions on how to migrate from Small Business Server 2003 to Small Business Server 2011. NOTE: This guide has been written using the preview version of SBS2011 therefore some of the screens may …
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question