dns server not working icmp host not reachable admin prohibited

I created a test environment  using vmware workstation creating host only vm's

linux server acting as my firewall and router dual nics (one on my reg. lan and one on my host -only lan

windows 2008 server (my ad and dns server)

i have everything working up to the point of i am able to ping google and get a reply so my dns is working and when i run a tracert from my windows client it is successful in finding the google servers

then when i go to the internet browser and point to google.com i get this page can not be displayed

i ran a tcp dumpand this is the error i get

09:31:26.100581 IP > ICMP host unreachable - admin prohibited, length 56 is my router /firewall (linux box) when i ping the i get a response

i am using the microsoft root-hints as my dns source

i am a little stumped  i would appreciate any help anyone can provide

Thanks in advance
Who is Participating?
dmf415Connect With a Mentor Commented:
check your iptables configuration.  This command may unblock icmp.
iptables -A INPUT -p icmp --icmp-type 8 -s 0/0 -d $SERVER_IP -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT

iptables -A OUTPUT -p icmp --icmp-type 0 -s $SERVER_IP -d 0/0 -m state --state ESTABLISHED,RELATED -j ACCEPT
eanda10Author Commented:
what would the server_ip variable set to?
Darius GhassemCommented:
Well seems like you are running host only vm's which only allow traffic on the host. You need to change the network settings within the Virtual Network to be external.
eanda10Author Commented:
but isnt that the point of the router to allow the network reach the outside world in this case the LAN
eanda10Author Commented:
Turns out to be an issue with some of my rules i went back to step one and flushed my firewall and rebuilt the rules and now all is good
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.