Solved

Outlook 2010 Defaults to Text Messaging

Posted on 2011-03-08
8
282 Views
Last Modified: 2012-05-11
I use Outlook 2010 with Exchange Server 2010.  If I have standard Internet email addresses (SMTP) for my contacts, everything works fine.  I create a message and the default name resolution is the last used email address.

If I receive a text message from someone (I am synchronizing text messages with Exchange for archiving purposes), Outlook 2010 wants to default to their text message address every time I create a new email in Outlook.  :(

Just because I want to archive text messages doesn't mean that I don't still want to create messages using the standard Internet (SMTP) email addresses that I have stored in my contacts' information in Outlook 2010.

Can I configure something somwhere to force Outlook to always use the Outlook contact's SMTP addresses by defualt instead of the text message address?

Thanks
0
Comment
Question by:Edward Stevens
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 7

Expert Comment

by:rogerard
ID: 35159316
It's most likely a configuration problem.  If you Click File->Options->Mail, you should see a section for compose messages where you can select text or html. see attached image.  Good luck!
htmlformat.jpg
0
 
LVL 1

Author Comment

by:Edward Stevens
ID: 35161010
Thanks for that suggestion.  It does change the default mail type from text to HTML and vice-versa but it doesn't have an affect on the default name resolution.
0
 
LVL 7

Expert Comment

by:rogerard
ID: 35164915
Doh!  I completely mis-read your question.  (maybe because I was only functioning on 3 hours of sleep, lol).  anyway, I'm not sure if this solution is applicable to your exact problem, but the symptoms appear to be similar.  See this article by microsoft to force Outlook to resolve names to the gac when in cached exchange mode.  Good luck!
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:Edward Stevens
ID: 35180599
Hi rogerard,

I looked throught he article and have a question for you.  I did not attempt the article's suggested fix yet because I wanted to see if you knew the answer to my question first.

The artricle talks about using the GAL for name resolution only (if I understand it).  I have 4 names (people) in my GAL.  All of the other 300 contacts are in my Outlook 2010 Contacts folder (external to my organization).

Question:  If I implement the article's change, will names in my Outlook 2010 Contacts folder be resolved because they are not in the GAL?  If not, this is not going to work for me.  If so, will it have any affect on my issue as my particular problem shouldn't be GAL related?  

To better restate my issue:  I have several, but lets just use one for now, contacts in my Outlook 2010 Contacts folder where I have a real SMTP address for them (i.e. user@Yahoo.com).  I also have their street address and cell phone numbers as part of their contact record in Outlook.  Up until I went to Outlook 2010 and Exchange Server 2010, if I typed in the user's name in the To field of an email message, it resolved to the SMTP address stored in the Outlook record (either email or email2, depending on what it memorized).  No problem.  After I started using Outlook 2010 and Exchange Server 2010, once I would receive a text message on my cell phone from the user, it would synchronize with Outlook.  That's fine.  I like having my text messages stored in Outlook/Exchange for archival purposes.  It is a cool feature.  However, if I was in Outlook and read the text message and then replied to it from Outlook (even just once), from that point on if I typed the user's name in the To box af an email in Outlook, the resolution would default to and only show the user's cell phone address (text message address).  What I want to do is have Outlook ONLY resolve to the SMTP address in Outlook's Contact record and not use the text message address.  Being able to reply to text messages from Outlook is a cool novelty but 99% of the time if I am using Outlook, I am sending a real email to a an SMTP address, not a text message.  I have "deleted" it in the resolution drop down but it will eventually show up there again over time.  Very annoying design on Microsoft's part.

Hope I was able to better describe to the issue.  I don't know that there is any fix to this issue but I thought I would post the question in case someone knew something.

Thanks!
0
 
LVL 7

Accepted Solution

by:
rogerard earned 500 total points
ID: 35181574
After some more digging, I think I may have found a tool that can help you.  First, let me start by saying, I'm not sure what rules Outlook uses to modify the autocomplete cache causing you the headache that it is.  What I suggest is a three part solution (for longer term sanity).  

1. Download NK2Edit

The first step is to download the NK2Edit Utility available from Nirsoft.  It appears that it will give you the ability to completely edit every aspect that is available of the NK2 file where Outlook caches its autocomplete addresses.  

2. Edit .nk2 file

The second step is to edit your existing .nk2 file and make the changes necessary to have your contacts reflect the correct address.

3. Backup, restore when needed

The final step consists of backing up this modified .nk2 file (usually located under your profile in Application Data\Microsoft\Outlook) to a safe location to use to restore from later when Outlook inevitably screws it up again.
I hope this is a better solution for you that will, at least, limit the headache caused by Outlook.  Good luck!
0
 
LVL 1

Author Comment

by:Edward Stevens
ID: 35181604
Cool.  Thanks.  I will download this and check it out.  I will post my results in a few days.  Income tax time.  :)
0
 
LVL 1

Author Comment

by:Edward Stevens
ID: 36214316
I would like to award the full points to rogerard for taking the time to look up this solution.  I also apologize for not getting back with my results.  While the ticket was open, my cell phone contract ended and I got a Droid.  Unfortunately, the Droid doesn't post the text messages to Exchange so I have no way of testing this resolution.

As a result, I forgot about the ticket being open as it is now a non-issue.  I do miss having my text messages stored in Exchange but as mentioned, I can't test with the Droid.
0
 
LVL 1

Author Closing Comment

by:Edward Stevens
ID: 36214337
Having switched cell phone types from Windows Mobile to Droid, I was not able to test the resolution but wanted to award the points for rogerard's time for looking it up.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
Outlook for dependable use in a very small business   This article is about using the Outlook application (part of Microsoft Office) in a very small business, or for homeowners where dependability and reliability are critical requirements. This …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question