Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

How to setup FTP site for WYSE thin client on XENAPP 5

Posted on 2011-03-08
5
Medium Priority
?
7,225 Views
Last Modified: 2012-05-11
Hello. We have a XENAPP 5 environment already in place and running that was only serving up apps and published desktops to Windows clients. We recently bought a few WYSE Xenith thin clients to try out. I tried setting up without the XEN.ini file, I can log in and see my apps list, but I get a SECURE CONNECTION TIMED OUT when trying to launch an app or desktop. I contact ed WYSE. They had me add my certificate to the Xenith, same problem existed. Then they said I need to use a xen.ini file and specifically use the fixlicense=clean option. I dont have any FTP sites running. WYSE said it can be done on a http (can I do it on an HTTPS)? I cannot find documentation on setting up a site to serve up this ini file. Any help would be appreciated. I am not familiar with setting up new sites in IIS.
0
Comment
Question by:ctna
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 
LVL 14

Expert Comment

by:Robin CM
ID: 35073265
See attached my xen.ini file, you'll need to put in the correct IP address for your time server (e.g. an AD domain controller)
On an IIS box you'll most likely have the following folder structure:
\inetpub\wwwroot
where inetpub is on the root on a drive (defaults to c:).
Within wwwroot create a wyse folder.
Within that create a wnos folder.
Put the ini file in the wnos folder.

Also get the latest fimware from Wyse, should be a file called C00_xen about 4.5MB and put that in the wnos folder too.

To make the files available via IIS, from IIS Manager (IIS 6), expand web sites, right-click default web site, click properties. Go to the HTTP Headers tab, click the MIME Types button. Add:
. text/plain
.ini text/plain
Think you may need to restart IIS, iisreset from a command prompt will do it.

The Wyse documentation explains some of this, but the folder structure and where to put the files within it was not overly clear. I had excellent support from Wyse over the phone, so call them if you're still stuck.
;*************************************************************************
;*                  Sample INI file (rename to xen.ini)                 *
;*      (Refer to Admin Guide for additional list of supported INIs)    *
;*                                                                      *
;************************************************************************

;; Wyse Xenith will only replace local engine if an upgrade is available

autoload=2

;; Specify a default domain to show at login page 
;; (remove ';' to enable)

;Domainlist=CITRIXDEMO

;; Specify timezone on client (in case of timezone passthrough)

'TimeZone="GMT - 08:00" 
TimeServer=10.1.100.1

;; You can choose to configure the location of XenDesktop server here 
;; instead of using DHCP Option Tag #181 
;; (remove ';' to enable)

;pnliteserver=10.100.4.200

fixlicense=clean

Open in new window

0
 
LVL 1

Author Comment

by:ctna
ID: 35074172
robincm. Thanks. I did create the /wyse/wnos folders already and had my xen.ini file in there. I followed your advice and added the MIME types (thank you!) I will restart IIS this evening. My Xen.ini file is very simple and similar to yours. I will try this in just about an hour and see what happens.
0
 
LVL 1

Author Comment

by:ctna
ID: 35075116
I restarted IIS. Didn't seem to make any difference. It does appear that my thin client is reading the ini file somewhat because in the (on the Xenith device) "Central Configuration", File Servers/Path shows 10.4.28.45/wyse (unless it is pciking this up from the DHCP options, 161 and 181).
0
 
LVL 1

Accepted Solution

by:
ctna earned 0 total points
ID: 35099166
This is ultimately what helped me: http://www.freewysemonkeys.com/modules.php?name=Forums&file=viewtopic&t=2030

I had to add the CRT to my xen.ini file. Even though I had added the .cer to the WYSE device, it would not work. So I did what the link above said, named my .cer to a .crt and configured the xen.ini file accordingly. I had to put the .crt file in C:\inetpub\ftproot\wyse\wnos\cacerts
0
 
LVL 1

Author Closing Comment

by:ctna
ID: 35135885
I had to wing it a little, but the link provided helped me find the answer.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

CITRIX XENAPP 6.5 FARM CUSTOM POLICY - CHANGE MANAGEMENT WINDOW REBOOT SCHEDULE
SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question